How do I get rid of this icon? I'm not even sure what it's for. It's possible that it's for remote CD Drive, but I don't remember how I got it up there in the first place.


  • iMac 27 inch late 2012
  • OS X Mavericks

1 Answer 1


The Eject menu is part of the Menu Extras that are of the standard core service items for the Mac.

It is not normally enabled.

But one way of enabling it is to double click on the /System/Library/CoreServices/Menu Extras/Eject.menu file.

The Eject menu is normally for your built in disc drive if you have one.

enter image description here

It may or may not work on external disc drive.

To remove the Eject Menu

  • Press and hold the Apple/Command key.
  • Click and drag the Eject menu icon off the menu bar.

  • Once you start dragging the Eject icon, you can release the Apple/Command key.

  • Release the mouse button when the Eject menu no longer appears in the menu bar.

    The Eject icon will disappear.

  • 4
    It may not have been enabled by default under older versions of OS X, but on my brand new 2013 iMac with Mavericks it was already there when I booted up the first time (I plugged in an external USB BD drive before powering up).
    – user11633
    Jul 13, 2014 at 15:57
  • 1
    Thanks for exact and step-by-step instructions. For some reason my Volume switched with Eject and this easily solved the problem.
    – Nahydrin
    Nov 11, 2017 at 18:52
  • Thanks a lot! 1. Press and hold the Apple/Command key. 2. Click and drag the Eject menu icon off the menu bar.
    – xgqfrms
    Mar 3, 2020 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .