1

Mid 2011 imac 27", which had a new hard drive installed afew months back. Since having a bad crash, the system had corrupt but seem get stuck in boot cycle on startup. I ran fsck on the hard drive but no problems were found and the drive was caught in some sort of boot cycle on startup.

I was able to boot from external drive with system and format the hard drive on the imac after I had backed it up. Only problem now is no method install a new system be it 10.8 or 10.9 seems to work.

I've created a USB 10.9 installer and I get the following error: Error screen shot

I also get a similar error when booting from a external drive with a bootable 10.9 system installed on it.

I am unsure the new hard drive installed in the imac is causing the problems or something else on the imac. Any help would be greatful as I think the only option I have left is take out the hard drive in the imac and replace with another new drive I have.

  • Have you also tried to install from a CD/DVD? – konqui Jul 11 '14 at 16:45
  • Yes I have DVD of 10.8 and it boots and starts to install but seems to hang on roughly 2 mins left to finish the install. – Ginger Mac Benn Jul 11 '14 at 17:39
3

This question is a year old but I am going to answer it incase someone else runs into this same issue.

I just bought a mid 2011 27" refurb iMac from IBM and they scrubbed the HD completely. This eliminated pretty much every option there was for installing an OS on the Mac.

The problem is that when these models shipped they had either Lion (10.7) or at the earliest Snow Leopard 10.6.6. They are not backwards compatible with the Snow Leopard retail DVDs Apple offers, which is OS X 10.6.3. These iMacs originally shipped with installion DVDs but Apple would not send them to me.

Here's what I had to do:

Download/or otherwise obtain an OS X 10.6.7.iso file from wherever you might find something like that. It will be an disk image for a DVD not intended for this model of iMac, and it will not work.

I bought the retail DVDs (10.6.3) from Apple, and they did not work. I got a RAM Error message (three tones) at boot.

If you have both you can splice the installer package files from the retail DVDs (which work with any Mac) with the installer package files from the 10.6.7 disk image and create a "universal" OS X 10.6.7 installer disk image. This is not fancy it's a simple matter of copy and paste. Detailed instructions for this process can be found here.

After I had the modified .iso file I converted it into a .dmg using this terminal code. Again, very simple. Nothing to be afraid of.

From there I used "Carbon Copy Cloner" and Cloned the .dmg file I created through this process unto a thumb drive (needs to be at least 8gb). Worked like a charm. Just pup it in a usb port and turn on the iMac.

You can also (possibly) use Disk Utility which is a built in utility and "restore" the image to your thumb drive, but I wasn't having any luck with my Disk Utility boot disks and so I decided to try another utility. My feeling is that it likely would have worked this way if i had used DU.

Make sure your thumb is formatted for GUID. Just a word of caution. I intend to upgrade to Yosemite. The install of Snow Leopard works, but I don't fully trust it and my Airport card is non functional. Certain things went wrong in the installation process obviously, but it's good enough to boot, and then upgrade, or maybe try to install a fresh unaltered version of Snow Leopard if that's your desire.

I hope this helps someone out. I've tried dozens of different ways to just get this iMac to boot an OS and this is finally the one that worked. Apple Support was zero help. Good luck!

  • I've since updated Snow Leopard to 10.6.8 and airport is now working. Everything is very smooth and functional. No problems.
0

This problem was later diagnosed by an Apple store as the processor being blown, which I said was slightly odd but they weren't willing to repair it.

  • It happens. I have had logic boards successfully repaird by this guy in NY: rossmanngroup.com He can reball a new CPU quite easily. He isn't the cheapest, but his quality is top notch. (I am not affiliated with him in any way other than being a satisfied customer) – Allan May 3 '16 at 15:59
0

I had this same problem. You can try holding down the option key or holding down Command (⌘) + Option (⌥) + R while starting up. It should then start (hopefully) in internet recovery mode which allows you to connect to the internet and download the version of Mac OS X that your iMac came with.

http://www.idownloadblog.com/2016/02/25/how-to-start-up-your-mac-in-internet-recovery-mode/

It worked on my iMac mid 2011 27" with an erased hard drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .