5

This has been happening on and off since I switched to a mac at work. Google Chome Helper occasionally runs my cpu into the red and has the fan spinning madly. Sometimes restarting Chrome fixes the problem, sometimes not. Eventually it always surfaces again.

8

The problem, in my case, seems to have been one of the tabs I always have open runs some crazy cpu-intensive plugin for ads (I suspect Grooveshark, but am not positive).

The fix was to go into Chrome settings (settings > content settings > plugins) and choose Click To Play. By default Chrome runs all plugin content as soon as the page is loaded - regardless of what is is, or how much memory it takes.

0

I found the issue for me was that some plugins needed to be removed (or disabled and enabled) - particular Markdown Here.

There's an ongoing ticket here about this bug, it's got something todo with Google Offline and Markdown Here, I disabled both and re-enabled them (in your Chrome Settings > Extensions). This fixed the problem!

How to fix High CPU usage Google Chrome Mac

This may be down to this plugin or some other, here are the steps I took to diagnose it.

  1. Open your Task Manager (In Google Chrome > Settings Icon > More Tools > Task Manager)
  2. Open your Activity Monitor (Used to view system wide CPU usage)
  3. View the CPU in the Chrome Task Manager, if any of the plugins are taking a significant amount of memory. Disable and Re-Enable them. The CPU usage should drop immediately.

View the open issues on markdown here's github page.

Note: You may have another plugin causing a similar issue. The idea is to view the chrome task manager and the CPU column to detect exactly what's causing the high memory usage.

If it's a plugin, disabling and re-enabling it may help. If it still continues, probably best to remove the plugin (and file an issue with the plugin vendor if possible).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .