1

I can see still see 'Hitachi' in the 'Devices' Sidebar, but I am not able to view folders and files on this Hitachi XL2000 2TB FAT32 Hard Drive (EHD) that is USB connected to the iMac below.

Late 2013 Apple iMac (27-inch Display 2560 x 1440), 3.4GHz Quad-core Intel Core i5, Turbo Boost up to 3.8GHz, 8GB 1600MHz DDR3 SDRAM - 2X4GB, 512GB Flash Storage, NVIDIA GeForce GTX 775M 2GB GDDR5, Magic Trackpad, Apple Wireless Keyboard and OS X 10.9.4 Mavericks

All was fine until I updated from OS X 10.9.3 to 10.9.4 earlier this week, so now when I double-click on 'Hitachi' it just loads and loads with nothing happening and never displays the folder and file contents of the EHD.

I have used OnyX and Apple Disk Utilities unsuccessfully to try and fix this problem.

Interestingly, Backblaze online backup still sees the EHD and connecting this EHD to a Win 8.1 PC also sees the EHD.

Further, I ran the commands below in 'Terminal' to make sure the drive was visible and got the following results which shows that the EHD is not hidden.

iMac:Applications john$ chflags nohidden /Volumes/Hitachi/ iMac:Applications john$ GetFileInfo /Volumes/Hitachi/ directory: "/Volumes/HITACHI" attributes: avbstclinmedz modified: 07/10/2014 23:26:44

Finally, I installed XtraFinder and am still not able to see the contents of the EHD.

  • Try the OmniDiskSweeper app to see the files. I think it is the indexing that is screwed up. Move the EHD out of Spotlight, then move back in. – Ruskes Jul 11 '14 at 8:13
  • Hitachi EHD had already been removed from Spotlight per System Preferences > Privacy > + > Hitachi to prevent indexing. – jwjb Jul 11 '14 at 15:49
  • Installed OmniDiskSweeper and folders and files on EHD. Also, I can navigate the folder tree with no problems, but when I try and open up a file it opens Finder which loads and loads and nothing happens. – jwjb Jul 11 '14 at 18:11

You must log in to answer this question.

Browse other questions tagged .