8

My mail app does not give me a viewer window and all File options are greyed out & not available.

iMac 3.06 intel core 2 Duo OS X 10.9.4

Mail opens in this state. I have created new user accounts and same problem exists. I have tried all suggestions, thanks, but still no joy.

When I re-installed OSX all data remained.

It worked normally in Safe mode.

  • 2
    Be aware, deleting an app does not change any settings back to defaults. Settings are stored in the user library. A good tip for troubleshooting any software issue is to always test in a completely new user account. If the same problem exists, its a system wide problem, if not, its a user account problem. – Fyrefly Jul 10 '14 at 19:55
  • Thanks for your suggestions. I have now tried all the suggestions above including re-installing the OSX to no avail. Still the same problem. I have all the same data on my Macbook, could I migrate that to the iMac? – Matt Jul 11 '14 at 13:14
  • CAn you please add some details about the problem. Do you start Mail and immediately get the problem described? What happens if you create a new user account on your Mac and run Mail there? If this works, add your email account and try again. – nohillside Jul 11 '14 at 13:53
  • 1
    When you reinstalled OS X, did you keep all your documents and data intact? (i.e.: all your stuff was still on there?) Like I stated above, reinstalling the app or the entire OS for that matter won't help you solve a problem that is a user account issue. – Fyrefly Jul 11 '14 at 14:15
8

Before you delete it, see if you can repair Mail.

  1. In Mail, go to Window → Connection Doctor and let it verify your connections to see if all works there.

  2. Next step is to rebuild your Mail database. Go to the Mailbox tab and at the bottom click on Rebuild.

    If 1 and 2 are not accessible (grayed out)

  3. Try to reset Mail settings. - which you will need to set up after following:

    Quit Mail, then go to Finder and press ⇧⌘G and enter (or copy) the following:

    ~/Library/Containers/com.apple.mail/Data/Library/Preferences
    

    Look for "com.apple.mail.plist" and drag it the Desktop, then restart Mail.

    • Alternatively, you can use this one-liner in your Terminal app (located in the Utility folder):

      killall Mail &> /dev/null; mv ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist ~/Desktop && open -a Mail
      

      Source: http://georgegarside.com/o/se/resetMail.html

If all else fails you can reinstall the operating system (Mavericks) that includes the Mail.app. Boot into the Recovery HD with ⌘R, then follow the instructions.

For more information about recovering a broken Mail.app, see this:

You can check if a 3rd party app/extension is causing the problem by performing a safe boot (hold shift on boot).

In rare occasions your user permissions or ACLs might need some repair. This answer describes the process.

|improve this answer|||||
  • @GeorgeGarside - thank you for the ☮ offer - accepted, let it be ☮ – Ruskes Jul 12 '14 at 14:12
  • ~/Library/Containers/com.apple.mail/ is locked now at macOS 10.14.4 and can not delete ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist. – FradSer May 25 '19 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .