I bought three movies on DVD on eBay. I am trying to make .iso backups onto my external hard drive. The first one I tried using Disk Utility, but it only produced a partial copy (without generating any errors) so I switched to using dd, which worked on the first movie. For both the second and third movie, dd only partially ran through before giving the following error:

dd: /dev/disk2: Permission denied 1438432+0 records in 1438432+0 records out 736477184 bytes transferred in 212.743197 secs (3461813 bytes/sec)

The number of records/bytes is similar, but not exactly the same, for both movies. I have no clue what else to try, since dd is as low-level a program I know to use. I have no idea why the error would be generated mid-copy like that. Googling for this kind of error leads to answers regarding improper filesystem permissions (I'm running sudo dd) and unmounting first (I'm also running sudo umount), and AFAIK neither would lead to dd working for the first 700MB and then getting that error.

Also, I have watched these movies all the way through without incident, so the filesystem appears to be good.

  • I've encountered this issue too. Rebooting has no effect, but if I take the same drive and disc to another macOS machine, it works. I tried in a different account and the issue is the same, so seems to be something related to the system. Jan 31, 2021 at 19:56

2 Answers 2


I've had some success. After trying a number of things unsuccessfully, including uninstalling packages that link into the filesystem, I found something that works reliably: load the disc using any software that reads the content and unlocks the encryption. Even the built-in DVD player works. Now after inserting a disc, I launch the DVD player and let the opening scene play. After that, dd seems to copy just fine.

  • This is the only thing that worked for me, thanks! What I did exactly: 1. Reboot the system. 2. Start watching the DVD using the macOS DVD Player application. 3. After a minute or so, quit the application. 4. Using Disk Utility, UNMOUNT the DVD, but don't eject. 5. ddrescue --no-scrape --sector-size=2048 --verbose /dev/diskX copy.iso copy.map
    – damd
    Sep 25, 2022 at 15:50

While writing this question, I remembered something I did different with the first disk and think I figured it out. For the second two disks I was using sudo umount /Volumes/DISK_NAME to unmount the DVD before running dd, which generated the permissions error, so I tried sudo umount /dev/diskX. This works, but only once per boot (it would fail again after one successful dd, until I rebooted). But can anyone explain why it worked? I thought the two invocations of umount were equivalent.

  • I ran into this problem, too. Indeed, it seems like the only solution is to reboot. I think the umount argument may be a red herring. Aug 17, 2015 at 7:32
  • I wonder if the "once per boot" happens because there's some other low-level service that's starting up, and once it starts up, it's somehow interfering with the device and disallowing the copy. Jan 31, 2021 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .