3

I'm using an editor that requires X11 and for the most part it works well. I have many commands that use the Alt key and I like to navigate the menus this way as well, but the Alt key doesn't work through X11.

I found this article on configuring the Alt key for X11 applications, but it didn't work for me. Any other ideas?

2

I think you want to check "Enable key equivalents under X11" in the Input tab of the X11 Preferences.

| improve this answer | |
  • Thanks for the reply. I already have that checked (the editor vendor had me try that). – Jeremy Mullin May 10 '11 at 14:53
  • 2
    I've found out this setting doesn't apply here. When enabled it means keystrokes like Command-N will be given to X11 (new terminal, in this case) instead of to the application itself. In my case I certainly want Alt-key to go to the application, not X11, so I have turned off "Enable key equivalents under X11". – Jeremy Mullin May 10 '11 at 18:59
1

The distilled instructions in this article worked for me.

in ~/.Xmodmap:

clear Mod1
keycode 66 = Alt_L
keycode 69 = Alt_R
add Mod1 = Alt_L
add Mod1 = Alt_R

and activate with xmodmap ~/.Xmodmap. The codes 66 and 69 can be verified with xev.

I did not change any other input settings. Note the op's article used Meta_R instead of Alt_R. I tested with an ssh-xforwarded app (eclipse).

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .