2

I recently got back to Mavericks from Yosemite, everything went fine. As I normally do, I checked my HDD with the Disk Utility and found some trouble, then I boot on recovery mode to fix my HDD. I realize that the recovery partition was the Yosemite one (It's easy to see since the UI is different)

I want to get back my Mavericks recovery partition, so I followed along this instructions.

But my diskutil list output is a little different:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         499.2 GB   disk0s2
   3:                  Apple_HFS EraseRecoveryHD         650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *496.1 GB   disk1

I deleted my recovery partition successfully with the command:

diskutil eraseVolume HFS+ EraseRecoveryHD disk0s3

But when trying to merge using this command:

diskutil mergePartitions HFS+ "Untitled 1" disk0s2 disk0s3

I get the following:

The chosen disk does not support resizing.

I don't know why my disk0s2 does not have a name and why do I have a disk1

BTW, I tried to avoid this trouble just by using the recovery partition I have (from Yosemite), I ran the repair disk option on recovery mode, then I booted on Mavericks and the disk utility says my HDD has the same problem as when I first checked.

-1

The simple solution is to reformat the whole disk and reinstall Mavericks from scratch. Doing so will get your Mavericks recovery partition back and you can migrate your data back from time machine. I get the feeling you don't want to do that however?

  • I thought that, but it will take me hours since my Time Machine backup is like 400GB. If I don't get a solution I will do that. :/ – Edu Jul 9 '14 at 17:49
  • BTW, the reason disk0s2 doesn't have a name, and you have a disk1 is because of the core storage, aka Fusion Drive technology you have in your machine. Your dealing with two physical drives that are made to act like one. – Fyrefly Jul 9 '14 at 17:51
  • 1
    That's strange, as far as I know my MBP has only one 500GB HDD (it's the early 2011 model) – Edu Jul 9 '14 at 17:58
  • That is strange then. You would usually only see "Apple_CoreStorage" on fusion drives, perhaps Yosemite does something with the partition tables and CoreStorage. My machine running Mavericks doesn't show any CoreStorage type partition. – Fyrefly Jul 9 '14 at 18:02
  • Now the only solution is clean install. i rebooted my Mac and It's broken. Which is the correct way to go? Boot from USB and install? – Edu Jul 9 '14 at 18:07
-1

Well, just I case this happens to someone else.

It seems Yosemite (beta 1) messes up with the HDD, as Fyrefly pointed out, Apple_CoreStorage represents two disks acting as one (for speeding up a HDD with an SSD). My MacBook Pro only has one HDD so that's strange.

After I deleted the recovery partition I rebooted my MacBook Pro and it died. So the only solution at that point was clean install. My MBP got into Internet Recovery mode, fortunately I had a Mavericks.app file so I created a bootable USB.

Use this command:

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

Note: Override with the path to your Mavericks.app file

I think this is the simplest and easiest solution, maybe Yosemite breaks more things so It's better to do a clean install. (In my case, Ruby was broken).

-1

As far as I know, the recovery partition is always created with the exact size of 650MB (1269536 sectors), regardless of hardware and OS X version. As disk utility will refuse to copy just the recovery partition, the next obvious option is to dd the stock 10.9 recovery from another machine/disk with 10.9.

How to go about this largely depends on what hardware you have available. If you have another mac with the correct recovery partition, just connect your mac in target disk mode and over-write the recovery partition from the other Mac's running system.

One important thing - stock 10.9 recovery probably doesn't support CoreStorage, so it will be of little use if your system volume is on the CS partition. And if you need to move the whole system partition off-disk anyway, then that defeats the purpose of copying just the old recovery partition.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .