5

I work in a research group whose employees use Mac Minis currently running OS X 10.9.3. The other day one of our employees mentioned being unable to get Thunderbird to start at login or cause Mail to not start--Mail was somehow set to start at login, and he couldn't change the setting persistently. Since then, we have found that no matter how we go about setting login options, they are ignored and reset upon logging out/in.

It may be worth noting that we use LDAP-authenticated accounts with homedirs mounted via NFS.

I've previously been through Apple's standard protocol of checking and changing these settings by right-clicking icons in the dock as well as in System Preferences -> Users and Groups, and checking the contents of /Library/StartupItems (which is empty), followed by deleting the ~/Library/Preferences file and letting the OS recreate it.

UPDATE: I've since found a workaround which is quite clumsy, but works. It appears to be some sort of strange issue with the permissions issued to ~/Library/Preferences/com.apple.loginitems.plist (though they are the same as the permissions for every other file in that directory). Running chmod 777 com.apple.loginitems.plist prior to making a single change, then waiting for the permissions to be reset before making each subsequent change to the list of login items allows the settings to work as expected. The file must again be chmoded prior to a reboot or it won't be read properly. In addition, these settings work as expected for the local administrator account, so I imagine the fact that we use network accounts is relevant. For whatever reason, I didn't think to check that prior to my first post.

  • 1
    If the user preferences are not maintained on reboot, then try to repair the users ACL's – Ruskes Jul 7 '14 at 18:16
1

Your workaround is the beginning of the right problem analysis. Verify that the ACL on ~/Library/Preferences are correct.

Let's say your user name is BOB. Within Terminal or xterm type:

$ cd ${HOME}/Library
$ ls -del Preferences
drwx------+ 9 BOB  staff  6324 Jul 31 14:10 Preferences
 0: group:everyone deny delete
 1: user:_spotlight inherited allow list,search,readattr,readextattr,readsecurity,file_inherit,directory_inherit
$

If your ACL aren't exactly as above, and most notably completly empty, check that your NFS server is correctly configured to manage ACL.

On your Mac which is the NFS client, check with the mount command that the noacl option isn't turned on.

0

This has happened to me before and we had to reset the login settings and turn if the computer, then it worked! Easy peasy 😉

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .