My iPhone 3GS has just developed an unusual problem. Audio will not come out of the loudspeaker, but the ear piece works, the headphones work and plugging into iPhone speakers via universal connector works. Oddly, the loudspeaker works when on a call and setting to loudspeaker.

I think the audio is constantly being routed through the universal connector, for the following reasons:

  • It tells me that the device is is plugged into is not compatible with iPhone, despite not being plugged into anything at all.
  • It connects to my speakers instantly, normally there is a slight delay is it needs to redirect the audio.

Also, I tried plugging it in and out of the speakers with audio running, without and it various other variations. One time I did get sound out through the speakers, but it only lasted 2 seconds before it returned to no audio.

Volume control has no effect unless headphones plugged in.

I have tried reboot and muting/unmuting several time.

1 Answer 1


Take a look at this Apple Support article. Not exactly your problem, but similar.

Basically, it says that it there's nothing clogging the audio-related components. If there is, it suggests cleaning them and tells you how:

If the speaker, microphone mesh, or top microphone (iPhone 4 only) appear clogged, please use a clean, small, dry, soft-bristled brush to clean them. To do this follow these instructions: Use the brush to carefully and gently brush the speaker and microphone mesh. Brush away from the 30-pin dock connector to avoid getting any debris into the dock connector.

And, if that doesn't work, Apple suggests that you get it serviced.

  • Cleaned the Univeral Dock Apaptor (or whatever the accepted term for it is) and hey presto! Nice One!!
    – Mild Fuzz
    May 9, 2011 at 8:21
  • @Mild huh? You mean you've cleaned the speaker output (which is right beside the Dock Adaptor), right?
    – cregox
    May 9, 2011 at 18:43
  • No, I mean I cleaned the adaptor. I adapted the answer to suit my problem, and came up trumps.
    – Mild Fuzz
    May 9, 2011 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .