13

I use the accessibility feature called sticky keys in OS X, what it does is that if you press a command modifier key (Ctrl, Cmd, Alt, Shift, Fn), it stays "pressed" until you press another key. This is very useful if you often use your keyboard with one hand, and actually quite convenient even when you use two hands.

The thing is that if you press a modifier key twice it stays "pressed" until you press it again. While it is sometimes handy, for me it would be preferable if this aspect of the functionality could be disabled, since I trigger it accidentally every now and then.

I realize that if this is at all possible it probably means fiddling with some system file somewhere, that's fine. I just want to see if someone out there might know where to look? :)

3

You can't turn off the "key lock" functionality (last checked on OS X 10.8.2). You can however install KeyRemap4MacBook, which allows you to make modifier keys sticky without this "key lock".

  • Thanks for the tip, I'll see if it's usable for me though. It's such a pity that there's no option for this, because sticky keys is such a convenient feature! – Erika Jun 15 '12 at 7:22
  • Ended up not using KeyRemap4MacBook, didn't feel comfortable with it. – Erika Feb 9 '13 at 8:56
  • 2
    just fyi, i added this setting to KeyRemap4MacBook yesterday. it's available in version 8.0.33; it's called 'Enable Sticky Modifier Keys (without lock feature)'. @Devon, i've been using it with lots of combined shortcuts like you mention, and it's pretty reliable. – ryan Mar 14 '13 at 17:15
  • @ryan, The problem with KeyRemap still exists, but I've created a proper bug report for it now. – Divinenephron Mar 14 '13 at 21:58
  • The KeyRemap4MacBook bug has fixed as of version 8.0.34. – Divinenephron May 12 '13 at 10:28
1

I believe you have to press it 3 times to release it.

  • First Press - Locks the modifier key, and unlocks it after the next key press
  • Second Press - Locks the modifier key for multiple other key presses.
  • Third Press - Unlocks the modifier.

Exmaple:

Pressing Shift twice while sticky keys is on would be the same result as turning on CAPS lock.

  • Sorry, but I'm asking for a way to disable the "locked" state altogether. I think it's pretty clear from the wording of my question. :) – Erika Jun 14 '11 at 18:35
  • Ah yes, sorry I misunderstood. I don't know of a way to do that. – maclema Jun 15 '11 at 13:10
1

I've seen this behavior even when "sticky keys" is turned off in system settings, by unchecking the "enable sticky keys" checkbox. I was seeing shift stuck "on" only for OS actions (not for normal typing) after coming back from a lock screen.

To resolve this, I turned sticky keys on (Mac Settings) and then toggled them off again using the shortcuts above.

  • I had the same problem! It was impossible to google, produced some strange behavior before I figured out it was as if I were holding Shift down. Yes, if your password includes capital letters, then Shift might get forced "on" after the lock screen. Just discovered that toggling sticky keys off and on solves the problem. – Luke Davis Aug 6 '17 at 16:21
0

go in to system pref, accessibility, keybord (left column) sticky keys, options, then "press shift five times to toggle sticky keys"

  • This disables the functionality altogether, the asker only wants to disable the "lock" part you get by pressing a modifier twice (but still use the single press functionality). – nohillside Jan 31 '13 at 5:36
  • my apologies, i misunderstood the question then – Macmaniman Jan 31 '13 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .