1

I upgraded my MacBook (Retina, 15", late 2013) to OS X 10.9.4 yesterday. Now Mail Version 7.3 (1878.6/1878.2) does not display conversations correctly:

  1. As you can see in the screenshot (ignore German localization) in the very right panel, not in the preview, the entire conversation is displayed, but the height of the messages is too small. I can even select all the text in a mail, but I cannot see it or increase the height.
  2. It takes more than one second (!) to display a conversation, no matter how many mails are in it. Used to be instant. Single mails are still displayed instantly.
  3. Sometimes the conversation indicator (e.g. that [2>] in the screenshot is missing even if it actually is and loads a conversation.

Mail is working fine if I disable conversations in the view menu. But I like the converation view and would like to keep it.

Broken output: mail screenshot current

Expected output (this is OS X 10.9.3 on my virtual machine): mail screenshot expected

I tried the following things

  • no logs in Console.app
  • I deleted all accounts and all mail settings I could find in my ~/Library/ - no change
  • I created a new user on my MacBook and entered one of my mail accounts - same problem
  • switched language to English - no change
  • compared md5 of /Applications/Mail.app/Contents/MacOS/Mail with other Mail.app's, it still d1911cc8cbdaabc61c409d65b262c5ee - binary not broken
  • Used my virtual machine with Mac OS X 10.9.3 (everything works fine), replaced /Applications/Mail.app with the version on my 10.9.4 system, still works fine - Mail.app is not causing the problems
  • compared sizes of /System/Library/Private Frameworks/Mail*.framework - exact same bytecount
1

I fixed the problem downloading the OS X Mavericks 10.9.4 Update (Combo) from the Apple website and installing it again. Either the App Store version was broken or something went wrong during the installation.

0

Testing on MacBook Air with 10.9.4 and mail 7.3:

To expand the preview window (right side) in the conversation view, there should be (I have it) a "see more from ..." in the first email (at the bottom of it, in blue font) of the conversation list.

Clicking on it shows full conversation for each email in the conversation group.

  • 1
    You are completely right, but that does not answer my question. I want to increase the heigth of the conversations on the right panel of the window. In the right panel, there were all messages of a conversation in full size. Before that update, I could scroll through the conversation and read every message in it. I do not want to increase the heigth of the mail preview and I do not want to click on that badge and click on the single conversation. I just want to click on a conversation and see all mails lines up in full height in the right panel. – valyron Jul 5 '14 at 12:09
  • Ok, I misunderstood. does it show the full message on the right when not using conversation view. – Ruskes Jul 5 '14 at 12:14
  • Yes it does. It displays a single mail instantly in full size as expected no matter if conversation view is enabled or not. It also does display a single mail in a conversion if conversation view is disabled. It's just the display of multiple mails on the dark gray background in the right panel that's not working. – valyron Jul 5 '14 at 12:17
  • I just played with my mail settings. So in Conversation view, fist click on the number to see all belonging to it. Now on the right hand site, in first email there should be "see more" (in blue font), click on that. – Ruskes Jul 5 '14 at 12:21
  • Like on that screenshot? As you can see above, I don't see that. – valyron Jul 5 '14 at 13:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .