So back story about my hard drive. I bought a USB 3.0 enclosure and a well rated and trusted brand WD 2tb hard drive to put in it. For many months now it had been running flawlessly on my iMac, formatted 100% as HFS+. After I decided to sell my iMac, I made a complete backup image of my iMac's hard drive as a single image file onto this external. It worked great and under Windows 7 with Macdrive installed, I could mount and access my old computer completely as if it was still running. (Note that the image file was 257gb in size, and I have about 1tb worth of self ripped movies, music, and my professional photography work.)

Now here's where I went wrong (as this is all my fault). My Windows machine has a vast library of games running on Steam's gaming platform. About 200gb worth. And I store those files on a separate hard drive than the boot drive of my Windows machine. The issue is that drive had some bad sectors and when Steam began to access files within, Windows would hard-lock on me and I'd have to cut the power. After it happened a couple times, I decided to make a backup of my files and try to fix the drive and reinstall Steam. Well I got as far as half the backup. You see, instead of trying to find what games would lock the system (by individually selecting a game and verifying the files in Steam to see which ones lock up the system) I just went ahead and ran the backup tool to place all the files onto my trusted external.

Halfway through the process the computer locked up and I had NO CHOICE but to cut the power and reboot. Upon entering Windows again, I'm greeted with a "you need to format this disc before you can use it" dialog. Great. Further inspection with Disk Management revealed the entire disc was not partitioned.

(Info about the working setup; I had one partition that spanned the whole disk but because it's a mac it had a small EFI labeled partition at the beginning. It is a 2tb drive partitioned at about 1.8tb. HFS+ filesystem of course, journaled.)

I attempted to run testdisk in Windows to find and restore the old partitions. First attempt found the correct partitions on quick analyses and the write function actually wrote it. Unfortunately no files appeared. So I rebooted with a gparted live cd to see what happened and decided to get rid of the partitions I just restored. I don't know what I was thinking...

Long story short, it was my fault and I'm desperate for getting my info back. Running testdisk from a Mac reveals HUNDREDS of found partitions in a deeper search.

My next thoughts are; would it be a better idea to format the entire disk from a Mac, to restore a standard disk layout of an EFI partition and the main partitions, and run a data recovery wizard? Or is my data long gone? I haven't written any information to any part of the disc except the partition map.

Some recent updates; I have located the correct partition and restored it with TestDisk. Unfortunately the partition is unable to be accessed still even though I know it's the correct partition. Do I need to restore the small 200mb EFI partition that Mac formatting creates? If so, would it be a valid solution to format the whole drive on a Mac (quick) and remove the large partition it creates and restore the partition I know is correct using testdisk?

Essentially I'm looking to restore the partition as if nothing went wrong. Where all my data is just up and running again. I am not adverse to recovering the data however, I don't have a large enough secondary storage solution to transfer recovered files to.

  • Did you eventually correct the partition, or recover the data some other way? Or abandon the data? I'm curious. Commented Aug 6, 2012 at 18:40
  • I would not begin an operation like this without Disk Warrior at hand.
    – Zo219
    Commented Jun 21, 2013 at 5:14

2 Answers 2



It worked wonders for me, and so did it for many other people. However, for very serious cases like yours, it took about 3 months continuously to completely restore all my data back. However, this requires a Mac.



It works wonders on any issue with normal hard drives, also works well as a maintenance tool to keep your drives in good shape.

If SpinRite can't save your data, then it will be way cheaper to just re-download the games than try and have the data recovered.

  • 2
    Something important to note is that SpinRite will only run on BIOS-based computers (i.e. not a Mac).
    – Graham
    Commented May 8, 2011 at 3:00
  • Alright so I actually had great success. It turns out the issue was more geared towards MacDrive itself. The issue being it REQUIRES the small 200mb EFI partition to exist on a disc or else it won't let you read or write to the list. Apple's build in bootcamp drivers (installed onto a non-mac) machine has revealed the rewrite of the new partition actually is the correct one that has all my files accessible now. The new issue is that I need to be able to write, ergo, I need to use Macdrive, ergo, I need to restore the EFI partition. Any suggestions?
    – Scott
    Commented May 8, 2011 at 4:37
  • Nope, sorry :/ From my first read, it sounded like you had a more general disk data issue, thats all :P
    – RCIX
    Commented May 8, 2011 at 4:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .