3

I've spent the last 2 days trying to install Mavericks on my MacBook 4,1. It is from Early 2008. It is unsupported, but I would like to install Mavericks on it. Is there a workaround for bypassing the system check or just generally getting it to install?

I've tried:

  • SFOTT (found out it's for Macs that have 32-bit EFI and/or processors; I have 64-bit versions of both)
  • Making a plain USB installer by using DiskMaker X (fails at the prohibitary (⊘) symbol when booting)
  • Doing SFOTT on a partition on the internal HD (same result as SFOTT)

Oh, and if you need it, here are hardware specifications:

  • MacBook 4,1; Early 2008
  • 2 GB 667 MHz DDR2 SDRAM
  • 160 GB internal HD
  • 2.4 GHz Intel Core 2 Duo
  • Intel GMA X3100 144 MB
  • 64-bit EFI and processor
  • Current OS is Mac OS X 10.7.2 (11C74)

And one more thing: I don't want to give up trying.

2

@Thinkling You were so close...I'm currently running Mavericks 10.9.5 on my Blackbook 4,1 Early 2008. Here's how:

Make a plain USB installer by using DiskMaker X, but after its complete, navigate on your new thumbdrive to: /System/Library/CoreServices/PlatformSupport.plist and completely delete that file.

Boot holding option key, select your thumbdrive, and install away.

Worth Noting: I had to install the kext file for my graphics (Intel GMA X3100 144 MB) to work properly, and I'm still fighting a no sound issue, as well as machine not sleeping with lid closed. Other than that, I've got Messages working, and haven't had any other issues in the month i've had it installed....

  • Where did you take the kext for the graphics card from? – nohillside Oct 3 '14 at 7:18
  • @patrix insanelymac.com/forum/topic/… – Richard R. Oct 16 '14 at 4:07
  • Hello @Richard R. I did what you suggested and I could boot from the pen drive with the installer (something was not happening before) . But after I selected the language I received a message that my computer was not compatible. What other things you changed in the installer? (Except for the model my Mac is compatible with Mavericks) – ePi272314 Apr 20 '16 at 15:21
0

Install 10.9 on a capable computer, then use the soft you like to make a ghost of your 10.9 fresh install on your old Macbook

  • Problem is, that this is the only Mac I have! – thinkling Jul 3 '14 at 23:06
  • has is worked the thomas answer? otherwise if you want you can help us porting yosemite on gmax3100 unsupported MacBooks here forums.macrumors.com/showthread.php?t=1761432 – user90149 Sep 9 '14 at 16:59
  • @Jonathan : If you want to reach thinkling, you should mention his name with an @ prefix as it's not his answer – Thomas Ayoub Sep 9 '14 at 17:48
0

So, if you really do not want to give up....

After endless attempts I managed to install Os X Yosemite Beta on my Macbook 4,1 (hardware the same)

Using this i made sfott usb. But after installation sfott on your USB-stick try to replace boot.efi BOTH in /System/Library/CoreServices/boot.efi AND /usr/standalone/i386/boot.efi It works on my own.

0

I installed Mavericks on my Macbook 4,1 manually, without fspott. I have working kext(s) for audio but had to use "sudo nvram boot-args="kext-dev-mode=1" and had to use graphics kext(s) from 10.6.2 Leopard. I still don't have QE*. If I catch some working GMA X3100 kext(s), I'll either go to Mavericks, or replace my logic board.

But, last time I checked, I couldn't find 2009 mid or last logic boards.

P.S. The install is not a problem. Follow the instructions listed here. For Mavericks, skip point 8d - it doesn't exist in Mavericks. It only applies in Yosemite. It works, but with too many bugs.

-1 funny fspott crash patch is realy bad, other don't boot, graphics crash with many another kext, only from 10.6.2 work stable. Read tutorial from link, clean, easy and work.

And x3100 64bit kext have same problems in SL, Lion, ML like Mavericks. I am curious because apple man say 10.9 can boot with 32 bit support.

-4

it is mostly like the video speed or memory, i know there is a way to fake out the cpu speed in the open firmware that's how i install leopard on a old g3 lol

good luck

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .