1

Whenever I try to connect to Screen Sharing on my 2012 Air from my Linux desktop, the Air's WiFi connection drops. I suspect this has something to do with Screen Sharing trying to present a login screen, and if I'm actually in front of the Air and I'm very quick on the draw, I can quickly re-select the WiFi network and get VNC to connect, but if I'm really "remote" I'm in trouble.

I tried

$ cd /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/
$ sudo ./airport en0 prefs DisconnectOnLogout=NO

as suggested for a related problem in this answer (adjusted for en0 instead of en1) but to no effect.

Any other undocumented prefs or other workarounds that might help here? Or do I have to install a third-party VNC server?

  • I have exactly the same problem, did you come closer to a solution already? – Bor Jul 14 '14 at 12:37
  • Nope, no closer. – David Moles Jul 14 '14 at 20:27
1

This happened to me with Yosemite, actually ran into a comment that worked for me here:

http://forums.macrumors.com/threads/mavericks-drops-wifi-when-connecting-in-with-vnc.1694085/

sudo defaults write /Library/Preferences/com.apple.RemoteManagement VNCAlwaysStartOnConsole -bool true

Another option would be to use wired, then it worked for me as well (no setting changes needed).

From https://discussions.apple.com/thread/4170694?start=0&tstart=0 it appears that "maybe" the root of the problem is that it's trying to revert to a login screen (and...doesn't do it right? mine definitely did not ever return to a login screen, it just killed the wifi). So perhaps there's a possibility that if you can get your "wifi" to remain active in login screens (and/or your mac "starts" at the login screen) then you could connect via WiFi and not have it disconnect, and not need the above. I could not find any way that worked for me to leave my wifi active while logging out, to test this hypothesis, but YMMV.

Another hint: when using wifi with "WPA2 Personal" and the above set to "false" when I connect, it actually works, VNC connects to a "new remote" session, not the currently logged in user (i.e. new login screen) (it also allows me to logout and not disconnect the WiFi, something the "Enterprise" wifi doesn't allow me to do at all). So my latest hypothesis is that "sharing" stronger encryption connected wifi "WPA2 enterprise" isn't allowed somehow (since it's also disallowed in the "Internet sharing"), and when it tries to open a new session, which is disallowed over the wifi ("sharing wifi" not allowed, for instance, in the sharing pane) it forces a disconnect. But connecting to the current user is OK.

  • I don't have that Linux box any more to test this, but it sounds very plausible. – David Moles Oct 22 '15 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .