2

My wife's iPhone 5 is exhibiting strange behavior:

  • It isn't receiving iMessages.
  • It can't access the internet.
  • It can send texts, but they come across as plain SMS instead of iMessage.

I'm sitting next to her with an identical phone on the same plan, and mine is working perfectly.

What's causing this? (Or, what should I google to find more information? My searches so far have proven fruitless.)

  • 1
    Is airplane mode on? How about cellular data? Is the phone able to send iMessages or access the internet on WiFi? – aglasser Jul 1 '14 at 21:33
  • Airplane mode is off, cellular data is on. – Joe Jul 1 '14 at 21:35
  • Try cycling cellular data (turn it off, then back on). Again, does it connect on WiFi? Try rebooting the phone completely (hold both buttons until the Apple logo appears). – aglasser Jul 1 '14 at 21:36
  • Over wi-fi it works fine: can access internet, can send/receive iMessages. – Joe Jul 1 '14 at 21:38
  • 3
    Cycling cellular data didn't help, rebooting the phone worked. Post that as an answer and I'll upvote & accept. Would love to know what causes this problem. – Joe Jul 1 '14 at 21:43
3

Try rebooting the phone by holding both buttons simultaneously until the Apple logo appears.

Restarting iOS will fix a lot of problems (as does restarting any computer) and should usually be tried as a first resort.

  • For some reason I'm still not thinking of my phone as a computer; obvious solutions like this are escaping me. – Joe Jul 1 '14 at 21:45
  • I'm not sure what caused your specific issues but a lot of these kinds of problems can be fixed by rebooting the phone. I've seen similar issues with iMessage not working (only green SMS) and rebooting fixed the issue. Not sure what causes them, but it is a computer just like any other - rebooting is a quick fix that restarts all of the system services (including what manages cellular data). – aglasser Jul 1 '14 at 21:46
2

Try this:

Setting > General > Reset > Reset Network Settings

You must log in to answer this question.

protected by Community Mar 15 '15 at 20:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .