2

I have one (just one) Exchange account configured:

Internet Accounts preferences

But Calendar shows it twice:

Calendars tab in Calendar

In the Accounts tab of the Calendar preferences it also listed twice:

Accounts tab of the Calendar preferences

and if I try to remove one of them I am redirected to the Internet Accounts settings (where only one is listed).

Calendar warning upon account removal

Is there a fix or should I completely remove the Exchange account and add it again?

1

Following the discussion suggested in the comments I was able to find a partial solution:

  1. In the Internet Accounts preferences (system-wide) uncheck the Calendars option from the Exchange account
  2. In the preferences of the Calendars application choose the Accounts tab and disable the only visible account
  3. In the system-wide Internet Accounts preferences re-enable the exchange account

The only drawback is that you will still see a disable Exchange account in your Calendars preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .