23

Basicaly my problem is, that when i mouse over some text, the default "text-selection" cursor appears. But the mouse pointer (arrow) is still present and i can see two cursors.

What could be causing this? It seems to happen when i "lock" my mac with the login window and then logging in.

Help?

I'm using OSX 10.9.3 on a late 2013 13" macbook pro with retina display and two atached monitors (one on a thunderbolt->DVI connection and another connected via the HDMI out)

  • Is this all applications or just some, if the latter which ones? – user151019 Jul 1 '14 at 11:20
  • on all monitors ? – Ruskes Jul 1 '14 at 11:26
  • All applications and all monitors, also the other "fake" mouse pointer is lagging like 10-50 miliseconds behind – Gabriel Jul 1 '14 at 11:29
  • thank you, one more, did you try using different user after log out log in? – Ruskes Jul 1 '14 at 11:37
  • No, since i'm the only user using this mac. But when it happens, i might try creating another user. – Gabriel Jul 1 '14 at 11:39
23

It just happened to me on 10.9.5 for the first time; don't know what caused it but unplugging the external monitor and then plugging it back again helped.

| improve this answer | |
  • 2
    This happened to me on El Capitan 10.11.4, and this solution worked. Thanks! – Steve May 7 '16 at 14:02
  • This worked for me, too, but I am unhappy with that solution. This happens to me sporadically, and I do screen capture videos often for my job, so it is frustrating. – Mike Williamson Sep 30 '16 at 22:34
  • Note that if you have multiple external monitors, you will likely have to unplug all of them. – Muhd Oct 31 '17 at 8:49
1

I am trying to figure this out as well -- it isn't just the the text selection cursor, but I think any cursor. I guess the problem is that the primary cursor doesn't disappear consistently. (It goes away when I start typing, but not while the mouse is moving.) I have 3 possibly related situations, only the last one (remote screen) has started recently:

  • big cursor
  • two displays
  • remote screen

I always use a larger-than-normal cursor, to find it on big displays. When I go to the Accessibility panel to reduce the cursor size now, it doesn't go down to the smallest size any more.

I've been running with two displays a long time without problem, but recently I started using Apple's remote screen capability. (I'm on a 2012 27" iMac, running 10.9.5.) I've used it in lots of different configs this week (one display, two displays, second display powered on or off).

Force-quit of system preferences doesn't fix the problem, but restarting did. Now my cursor is small and there's only one at a time. Increased the cursor size, still no problem.

So my bet is this is a minor bug with the Accessibility software interacting with remote display usage. But hey, your mileage may vary.

| improve this answer | |
1

I had a double cursor, or it looked like a cursor and a "shadow" on my external monitor.

It was on both my laptop display and the external monitor.

I unplugged the external monitor and the cursor was fine on the laptop. Plug the external monitor back it, now it's 50/50 - move to the MacBook display, single cursor - back to external monitor, double cursor - back to the MacBook display, single cursor - back to external monitor, double cursor, etc.

I clicked the Apple symbol, System Preferences, Accessibility, then reduced the cursor size and then increased it again, problem solved.

So, it's a software bug. I'm running a MacBook Pro 17 inch late 2011 with Sierra 12.12.2 Beta

| improve this answer | |
0

I see the same thing here on OSX 10.11.6

I have an external monitor so all I have to do is unplug and replug the monitor back in and the problem goes away.

| improve this answer | |
0

Same problem here. I'm using 10.12.2 and an external display (laptop closed). I went into the accessibility and moved the cursor size slider up and down and problem fixed itself.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .