1

Problem occurs when pressing the @ and the " keys. They seem to be mapped to each other, so @ -> " and " -> @. The system preferences allow modifier keys to be re-mapped but not these two. Can it be done?

  • 1
    Normally this is just a matter of setting system prefs/keyboard/input sources to the layout which matches your hardware, probably "British PC" in your case. Also there are others you can download and install if needed, such as liyang.hu/osx-british.xhtml – Tom Gewecke Jul 1 '14 at 9:27
3

That sounds like the main difference between a US and a UK keyboard. On a UK keyboard the " is above the number 2, and on a US keyboard the @ is above the 2.

Is the keyboard UK or US?

And is the Mac set to have a UK or a US keyboard attached?

2

use keyremap4macbook. It adds all these options and it's easy to add new mappings on your own - eg for media keys and so on. Also you can make the remaps device specific so a mac keyboard will work as usual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .