I finally understood why Disk Utility will not change the partitions on my HDD, even though I added the most recent one myself (maybe significant: to test Yosemite DP) with it. Now I see it says it won't change either partition, because it has encrypted data and CoreStorage objects. It tells me vaguely to use diskutil from the command line for this, but this makes me a bit uncomfortable. I found a very similar question here, with a great but incomplete answer about how to resolve this. How can one drop the smaller partition, then?

Note that I don't even see my pain partition from diskutil corestorage list (output below), which is worrisome.

Also note (also in the older question) that the name of the disk is unstable, sometimes Disk Utility lists my original, old name for the disk (Toshiba…), sometimes the name of the new, smaller partition. Note that I made these partitions from within Mavericks, not Yosemite. Why would Yosemite mess with this?

My relevant Terminal output:

d2m66h2j:~ laszlosandor$ diskutil list; echo; diskutil cs list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            289.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:          Apple_CoreStorage                         29.3 GB    disk0s4
   5:                 Apple_Boot Recovery HD             650.0 MB   disk0s5
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS OS X Test              *28.8 GB    disk1

CoreStorage logical volume groups (1 found)
+-- Logical Volume Group B6308EC8-297D-44BD-9212-6BD867F6331B
    Name:         OS X Test
    Status:       Online
    Size:         29349998592 B (29.3 GB)
    Free Space:   204955648 B (205.0 MB)
    +-< Physical Volume 3325F333-C8E3-46EE-9357-5E0C21A600D1
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s4
    |   Status:   Online
    |   Size:     29349998592 B (29.3 GB)
    +-> Logical Volume Family E8CB0EB7-A2B7-48AA-AA13-5DE30867901B
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        +-> Logical Volume 2F7B1893-07E8-4194-840B-F2552042E055
            Disk:                  disk1
            Status:                Online
            Size (Total):          28809494528 B (28.8 GB)
            Conversion Progress:   -none-
            Revertible:            Yes (no decryption required)
            LV Name:               OS X Test
            Volume Name:           OS X Test
            Content Hint:          Apple_HFS
  • 1
    Can you please update your post with the output of the following command: diskutil list; echo; diskutil cs list
    – njboot
    Jun 30, 2014 at 20:09

3 Answers 3


I highly recommend completely backing up the machine before attempting this, either using TM with no exclusions set, or better yet, cloning the whole drive using a program like Carbon Copy Cloner.

Unmount the Logical Volume:

sudo diskutil unmount force /dev/disk1

Remove the Logical Volume Group and all of its contents:

sudo diskutil cs deleteLVG B6308EC8-297D-44BD-9212-6BD867F6331B

From diskutil's man page:

  delete | deleteLVG lvgUUID | lvgName
           Delete a CoreStorage logical volume group. All logical volume families with their
           logical volumes are removed, the logical volume group is destroyed, and the now-
           orphaned physical volumes are erased and partition-typed as Journaled HFS+.

Merge the now orphaned partition disk0s4 into startup volume disk0s2 (note: disk0s3, one recovery partition, will be erased and merged as well). disk0s5, the other recovery partition, shouldn't be affected:

sudo diskutil mergePartitions HFS+ "Apple_HFS Macintosh HD" disk0s2 disk0s4

Again, from the man pages:

 Merge two or more partitions on a disk.  All data on merged partitions other than the first
                will be lost.  Data on the first partition will be lost as well if the force argument is

                If force is not given, and the first partition has a resizable file system (e.g. JHFS+), the
                file system will be preserved and grown in a data-preserving manner; your format and name
                parameters are ignored in this case.

Verify the boot Volume structure.

diskUtil VerifyVolume /

Verify the partition map:

diskutil verifyDisk disk0

Boot into Recovery Mode, or Internet Recovery if needed -- if any errors appear:

You should be left with:

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            319.7 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
  • This is a great answer. I am a bit hesitant to try it (or to buy a large external HDD and spend a day backing up just to try this — my online backup is on Amazon AWS with Arq, but not the entire disk). But I will see what I can do and accept your answer, or maybe even sooner if others say it solved the same problem for them. Thanks!
    – László
    Jun 30, 2014 at 23:25
  • 1
    @László You're welcome. I just tested this on a spare boot drive to confirm, but as I said, I would not ever do this on my main volume without an up to date backup (or two!). You should always have a backup my friend, no matter what! These Toshiba drives are excellent - I use them all the time BOL. Cheers.
    – njboot
    Jul 1, 2014 at 0:15
  • This basically worked, things look great – apart from the fact that both of my Recover HDs are now gone. How big a problem is that? Why did that happen? Shall I fix this somehow? How? Thanks again!
    – László
    Jul 1, 2014 at 21:43
  • 1
    Thanks for this. I used the first two commands to delete the partition, but since I was a bit wary of using mergePartitions, I went to Disk Utility after that. The Partitions tab was no longer greyed out, and I could take it from there (delete "unused space"/orphan partition, resize disk, add new partition.)
    – Mark Bao
    Oct 17, 2014 at 0:40
  • 1
    I had a corrupt Fusion Drive partition which Disk Utility refused to reformat. I followed the first two steps of this procedure (with the difference that because I rebooted with a recovery drive I couldn't use sudo and the distil command was diskutil unmountDisk). I couldn't do the mergePartitions command because the partitions are on different physical disks, but when I switched back to Disk Utility it automatically recognized the deleted LVG and offered to rebuild the Fusion Drive. Success! Thanks for getting me on the right track.
    – ghoppe
    May 15, 2015 at 16:13

I know this is an old article, but this recently happened to me and the easiest way to get rid of the Yosemite partition is to:

  1. Boot your other OS, mine was Mavericks
  2. Open Disk Utility
  3. Select the Yosemite partition
  4. Select the erase tab, erase it,
  5. Select the main drive and go to the partition tab, where you can then delete the Yosemite partition and resize it back to the original size.
  • This is exactly what was supposed to work but did not, thus the original question. But thanks!
    – László
    Aug 19, 2014 at 15:09

ran into the same problem and found this article that fixes it a little easier

Just run diskutil coreStorage list, find the logical volume uuid,

and then run diskutil coreStorage revert (that uuid)

in your case diskutil coreStorage revert 2F7B1893-07E8-4194-840B-F2552042E055


  • Revert only works if it was created from convert. Mine were created straight up by an erase operation in Disk Utility.
    – Almo
    Feb 14, 2018 at 1:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .