I have a late 2011 13″ MacBook Pro with OS X Mavericks updated to the latest version, which was usually connected to a HP Pavillon 23xi monitor using a Mini DisplayPort to VGA adapter. It worked like a charm as desktop extension until 3 days ago. When I woke up the MacBook it didn't detect the external display.

I connected the screen to another laptop using the same VGA cable and it worked. So the screen and the cable are fine. I ran a live cd of Xubuntu on my Mac, and recognizes the screen perfectly, so the adapter and the Mini DisplayPort works properly.

However when starting with OS X, sometimes it doesn't detect the external screen, sometimes it detects it, and extends it, but the external screen is black. I can move the mouse to the second desktop, but logically I can not see what is in it. It worked perfectly well until 3 days ago. I Googled for a solution, and I tried the following with no luck:

  • Resetted the PRAM with alt + cmd + p + r until I heard the startup dong 3 times
  • Resetted the SMC with ctrl + alt + left shift for a few seconds and releasing all keys at the same time.
  • Reinstalled OS X Mavericks.
  • Restored a Time Machine backup of a month ago (when the screen worked properly).
  • Repaired 2 times the permissions of the disk.
  • Verified that I had the latest EFI and SMC firmware.

I've done all this and still have the same problem. (I think I need to reset something, but I don't know what else I should do.)

  • 1
    if you log in as different user does it work ? open console then watch it, while you plug in monitor leave in 1 minute then unplug (anything there)
    – Ruskes
    Jun 29, 2014 at 18:08
  • I have only one user. But things have gone really weird. While I was surfing the web suddenly the external display started to work! I had to go for a while and the mac went to sleep mode. When I returned and woke up the mac, the external display was no longer recognized. Hopefully I collected "system.log" here: dropbox.com/s/lstpevutt86ipsn/log%20pantalla%202.rtf . For your reference, the external display started to work at around 21.50 and I woke up the mac when I returned at 22.50, as I can confirm from the log that there were activity from "WindowServer"
    – daca11
    Jun 30, 2014 at 6:55
  • This morning I turned on the computer and it didn't recognize the external display at first. But then I logged on from Teamviewer at work and it suddenly changed resolution to 1920x1080 so I think it re-detected the external display again. The logs from boot to the detection of the display are collected here: dropbox.com/s/bgh72xwqf0fr10s/log%20pantalla%203.rtf
    – daca11
    Jun 30, 2014 at 7:00

5 Answers 5


Seeing that this question has become popular, I will tell you how I resolved the issue...

I was using a fake adaptor, but it worked with Mac OS X flawlessly for two years. Strangely, it only works now when booting with other systems (like xubuntu live cd).

What I did to solve it was buying an original adapter from Apple.. I hope it will last until my Macbook becomes useless..


Open the ColorSync Utility app (in your Utility folder)

Look in it for your external monitor.

If it is there reset the profile to factory setting.

  • Here are your 2 displays

    Jun 29 21:40:33 MacBook-Pro-de-yourName.local WindowServer[131]: Display 0x042732c0: Unit 0; ColorProfile { 3, “HP 23xi"}

    Jun 29 21:40:44 MacBook-Pro-de-yourNmae.local WindowSe rver[131]: Display 0x042732c0: Unit 0; ColorProfile { 2, “Color LCD"}

The below has nothing to do with your monitor but I found the problems in your log, so if you care to fix those as well: :)

  • You should Disable the Clean My Mac (it is know to cause all kind of trouble).

Google Auto Update

  • Your Google auto-update is not working well, either fix it or disable it.

Instructions here:

Jun 29 22:12:04 MacBook-Pro-de-yourMac.local GoogleSo ftwareUpdateDaemon[1436]: -[KSUpdateEngine updateProductID:] KSUpdateEngine updatingproduct ID:”com.google.Keystone"
  • SMC Errors

You have few SMC errors.


Jun 30 07:51:58 localhost kernel[0]: SMC::smcReadKeyAction ERROR: smcReadData8 failed for key LsNM(kSMCKeyNotFound)

Did you install any programs that can allow you to manually control your hardware like SMCFanControl?

In any case it is recommended to reset your SMC, and uninstall 3d party software.

Back to Monitor:

Your system has a problem indemnifying the correct monitor, and setting the correct profile for it. As of now I do not know why.

  • The external display wasn't listed in ColorSync utility as it didn't recognized it... but the color profile HP23xi was there. After waking up the mac from the sleep (from the first log I shared), the color profile disappeared..
    – daca11
    Jun 30, 2014 at 7:03
  • the HP23xi profile was there from last time when monitor worked. The profile should be still there at the bottom of the profiles list under Other. What I want to know is when it works open and look if it has more then one profile for your monitor.
    – Ruskes
    Jun 30, 2014 at 7:36
  • There is only one, and it's the factory setting one. When I click on "others" I can choose between the HP profile or the Color LCD which is the profile for the macbook screen. See screenshot below: dropbox.com/s/77bz6b46tkil82i/…
    – daca11
    Jun 30, 2014 at 8:56
  • Hi, I am still working my way true your Console log. Meanwhile, could you disable the CleanMyMac since it is known to make problems.
    – Ruskes
    Jun 30, 2014 at 9:10
  • Hi, thanks for your quick replies! I'm not using any software to manually control hardware. I uninstalled CleanMyMac and disabled google auto updates as they say. I resetted SMC again, but I don't know if I'm doing it right or not.. When the mac is off I press at the same time left shift + ctrl + alt + power button for a while, but nothing happens or indicates that the SMC has been resetted.. The mac doesn't boot up unless I only press the power button though. Despite all, my external monitor still doesn't work properly..
    – daca11
    Jun 30, 2014 at 15:39

I had the same problem and I used gfxCardStatus v2.3 to switch to Discrete only graphics card and now it works.


I am not a Mac expert. I had a similar problem using the display port. No picture. After a day of assuming it was my Mac, I decided it might be my monitor. I discovered that my monitor was not set to displyport; so, I was getting no picture. If you run out of options, you might try changing yur monitor's "display port" configuration and make the required changes.


I had an almost identical problem. Mac early 2011 15" 2.3 i7 recognized that another monitor was plugged in , but it the monitor was not detecting a signal.

Unplugging and re-plugging in the monitor caused mac to respond as expected, it stopped seeing external monitor, then saw it again when it was re-plugged in.

Since the Mac was seeing everything I thought it might be the monitor not recognizing the input.

Hard power cycling the monitor ( unplugging the power supply from the back of the monitor and re-plugging it in) worked to reset the monitor ; where as simply turning the power switch on monitor off and on did not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .