Am I missing something or is the search function in the special characters window not very helpful? For example, I'm editing text and I want to insert the character for π (pi), so I select "Special Characters..." from the menu and get the window. Then I type "pi" in the search field and get the following, which is not helpful.

enter image description here

Next I try "greek pi". The search results are still surprisingly useless, but it did find a character with name "greek pi symbol". It failed to find the characters I really wanted because they have names like "greek small letter pi"

enter image description here

enter image description here

So to find the character you need to know it's exact unicode name? That doesn't seem right. Is there a better way to search for a character?

This is OS X Mavericks.

  • π like the letter p with alt key pressed ? – Buscar웃 Jun 29 '14 at 18:19
  • Yes, that one. Thanks for that reminder, but most of the keys I find myself needing are not in the option keyboard. – Rob N Jun 29 '14 at 18:53
  • ok, lets agree that the search function sucks, if you use the keys frequently you can customized them, so when you type pi it will insert it. – Buscar웃 Jun 29 '14 at 18:58
up vote 1 down vote accepted

Ctrl+Option+Space in 10.9.x brings up a quick access to special characters in line where you're typing —throughout most every app.

The search algorithm is the same of course, which it seems relies on how the charicter is tagged rather than a smart search throughout.

Still, in general, I have found the quick access shortcut and search to work well for most things. If you start typing while the special char fly out is open it will run a search.

Interestingly, While it seems that some older special characters like π have names that need to be entered exactly to search for them "small greek letter pi = π", emoji will display if just part of the name is searched. "Person with blond hair=👱" can be searched just by typing in blond.

enter image description here

enter image description here

enter image description here

enter image description here

  • 1
    Cntl+Opt+Space is doing nothing for me, even in TextEdit. I'll poke around system prefs to see if I can turn this on somewhere. – Rob N Jun 30 '14 at 14:21
  • Ah, I see. That's actually the same dialog pictured in my question, but you can toggle between the full window and this mini window by clicking that button next to the search field. It's Cntr+Cmd+Space for me. – Rob N Jun 30 '14 at 14:25
  • 1
    I've accepted this answer, but I've also filed a bug report with Apple. Their search field is doing exact string match, when it should be working like a normal, more powerful, text search. – Rob N Jun 30 '14 at 14:51
  • 2
    Ctrl-Cmd-Space in Sierra – Robert Mooney Jan 16 '17 at 21:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.