2

A bit of info about my configuration

OS X: Mavericks
iOS: 7.1.1
Hardware: iPhone 5s and BacBook Pro (Late 2013) 
They are both on same Wifi network.

Problem

iTunes doesn't recognize iPhone's remote app in any way.

What I tried

  • Reinstalled OS X
  • Reinstalled Remote app on iPhone
  • Reinstalled iOS
  • Resetted Wifi router (There is no problem with router. It worked with same configuration about half year ago)
  • Tried with and without home sharing
  • Deauthorized and reauthorized iTunes
  • Signed out of Apple account and signed in on iTunes
  • Turned off OS X Firewall
  • Reset iTunes configuration
  • Tried to switch WiFi signal channel

Neither iTunes nor iPhone doesn't recognize each other. Any suggestions?

  • Two questions, what is the "iPhone's remote app", and have you tried to create an 'Ad-hoc' wifi network using your MBP, and use that as you WiFi connection for the iTunes. – CousinCocaine Jul 7 '14 at 11:23
  • @CousinCocaine Remote app: itunes.apple.com/us/app/remote/id284417350?mt=8 – Dillon Jul 7 '14 at 14:17
  • @Patience Ah, that one. It is most likely your router than. I had similar issues and only got it to work on my Apple router. You will notice that creating an Ad-hoc accespoint with your mbp will fix your issue. – CousinCocaine Jul 7 '14 at 14:18
3
+25

To answer your question. I have the same configuration as you.

OS: Mavericks iOS: 7.1.1. Hardware: iPhone 5s and MBP Late 2013 They are both in same wifi network.

This is what I did:

I selected "Create Network" from the wireless icon in the menu bar. I did not specify a password. I was able to use the iPhone Remote app without failure. Since then, I've reconfigured it with a password and it also works without error.

|improve this answer|||||
  • 1
    Lol, so I need to exit current router's wifi to mbps network? Sorry but this is not solution – Tural Ali Jul 7 '14 at 15:41
  • @TuralAliyev This is a known issue with several routers. Apple has not officially announced a list of compatible devices. After researching many forums and Apple's support page, I was left with the aforementioned workaround. I am frustrated with Apple's configuration as I've had several incompatibility issues. – injector Jul 7 '14 at 15:47
  • 1
    @TuralAliyev, Dark_Cyber is right. You said the router wasn't the issue, but we are still not certain. Try the ad-hoc network, if that works, then your router IS the issue. – CousinCocaine Jul 7 '14 at 16:38
  • @CousinCocaine Like I mentioned in my answer, I had the same issue as TuralAliyev. It wouldn't work until I tried the ad-hoc network option. My DLink router WAS the issue, but I still believe that Apple should be able to configure their product/application/devices to work with most devices. Considering that I tested this on two different routers: a Dlink and a Linksys router. Both are pretty popular routers. – injector Jul 7 '14 at 16:41
  • 1
    @TuralAliyev and @Dark_Cyber; unfortunately this is a common issue and affects me as wel :( – CousinCocaine Jul 10 '14 at 7:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .