3

I've updated to Mac OS X 10.7.5 and now the autocorrect no longer works as beautifully as it used to. Prior to update, whether I was in mail, safari, wherever, it detected the language & suggested the appropriate correction…now it is only detecting one language (the first on my list in settings) and doesn't detect when I'm using the second language on my list in system preferences.

Can I revert back to the previous software versions b/c this is really frustrating?!?!

…or does anyone know how to fix this??

2
  • have you looked in the sys -> pref-> keyboard-> Text ?
    – Ruskes
    Jun 29 '14 at 13:20
  • Under keyboard there is keyboard & text but that has to do w/shortcuts…
    – info
    Jun 29 '14 at 14:03
2

You should find the setting in your System Preferences.

Select Automatic by language or your choice.

spelling

5
  • In Mojave everything looks differently, there is no auto option. How to enable this, now? Feb 26 '19 at 11:52
  • 1
    @modiX Sorry about that, this post is 5 Yr old, but for Mojave you will find it in System Preferences > Keyboard > Text
    – Ruskes
    Feb 26 '19 at 16:12
  • No need to say sorry, as you said it's 5 years old. Thanks for the reply, there it is, but it's already rightfully configured at my system, yet it still fails to spell check my 2nd language, even when I added it to the region settings. Any clue? Feb 26 '19 at 18:24
  • @modiX I do not have Mojave, just High Sierra, I also use 2 languages and spelling works Automatically on both. English and German :)
    – Ruskes
    Feb 26 '19 at 18:56
  • I noticed that it always wanted to spell check only one language in one specific app. Now I found a spell check context menu when I right click in that text box where the spell checking is not working how I want, and see there, it was not set to auto, didn't know this can be customized for each text box or app, no idea how this was set in the first place, but now it works. Thanks for your time, nonetheless. Feb 27 '19 at 10:15
0

In System Prefs/Language & Text/Text/Spelling, go to the Setup item on the list and make sure that only the languages you are interested in have their boxes checked. You need to also check that Edit > Spelling and Grammar > Show Spelling and Grammar is also set correctly in the app you are using.

That is the best you can do. I've rarely heard of anyone who thought Apple's multilingual spellcheck was very satisfactory. But it should detect both languages, unless one of them is a 3rd party add-on dictionary, in which case there is no guarantee.

If by chance you are talking about the Pages app or Word, let us know, because the above is not relevant for that.

1
  • thank you…I've checked this in mail and it's once again working as before. In safari, however, it's not working. For example prior to the update if I'd type a post on my Facebook Business page in Dutch, it would recognize and suggest spelling correction where necessary…now it only recognizes English…I was actually most always quite happy with the spell 'check' prior to the update…it was mostly correct!
    – info
    Jun 29 '14 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .