2

I recently noticed that TM does not update its backup from certain folders any more.

I have a deep sub folder inside ~/Documents, and when I create new folders or files in it, they do not appear in the TM backup. The backup contains, however, lots of files created until Oct 2, 2013. Which means that TM used to backup the contents of this folder.

Now, before you suggest that I have probably disabled backup for this folder - nope:

  • When I check with tmutil isexcluded for paths of files that didn't get backed up, it says [Included].
  • When I then added another disk as a second backup destination, that backup does contain the missing files. This proves that the source is accessible and can be backed up. So, any suggestions that the path may contain invalid chars or is too long doesn't apply, either.

Somehow the existing backup got stuck, preventing it from updating these particular folder contents.

  • The system log does not show any messages related to this.

  • A disk verification with Disk Utility does not show errors, either.

I could just erase the entire backup and start over, but I would rather not lose my previous versions.

Any ideas how to possibly "reset" or fix the backup so that it backs up the missing files again? I suspect that there's some kind of database that TM maintains to be able to quickly browse its backup folders, and maybe that's corrupt somehow, but I cannot find one.

Here's another idea: If the source disk was modified without OS X watching over it (thru fsevents), e.g. by booting from another system, the TM detects this and starts a complete comparison again, right? I wonder if I can trigger that, and that this will fix the issue.

In the past I've seen knowledgeable people indicate that TM backups can get broken once the backiup gets full and needs deletion of old versions (this is the case here), but no one was able to explain what exactly goes wrong and whether this can be fixed. If you know more details, please comment. I just might write a tool for that in the end :)

(I am an advanced Mac user and programmer; I am using 10.9.3)

1

What actually helped was to identify the folder inside which no file changes were detected, and then rename that folder and force a backup. Then all new content inside it got added to the old backup. After that, I renamed the folder back to its original name, added another file inside and did another backup - again, the new file got backed up.

So, somehow, that folder got stuck, and by renaming it, I could reset the backup for it.

Still, I will keep an eye out for other folders that may not get backed up, using the tmutil compare command regularly.

You just can't trust Time Machine.

That's why I also use CrashPlan as a secondary, and offline, backup.

  • BTW, I've filed the issue with Apple (rdar://17509234) – Thomas Tempelmann Jun 30 '14 at 19:05
0

Try this (You shouldn't lose any old backups):

  1. Turn off Time Machine in System Preferences (make sure it is not backing up, if it is, let it finish).
  2. Disconnect the hard drive
  3. Delete this file: sudo rm -rf /Library/Preferences/com.apple.TimeMachine.plist (you will need your root password, usually the same as your login password if you are admin).
  4. Shut down your Mac and reset the PRAM. (Shut down mac, press the power button, hold down command(⌘) + option + p + r BEFORE the gray screen appears. Keep holding until you hear the startup chime for the second time. Computer will then boot)
  5. Reconnect the hard drive
  6. Re-enable Time Machine in System Preferences
  • I had already tried that. Not helping the issue. – Thomas Tempelmann Jun 30 '14 at 9:31
0

this might help. not sure. I moved away from Time Machine a while back due to issues like this.

How to force a Time Machine deep traversal?

sb

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

0

Remove the /.fseventsd folder on your drive, TM is using the information from the fseventsd daemon and this way you force TM to do a deep traversal of the drive.

Kill the fseventsd daemon (the daemon starts automatically) after you removed the /.fseventsd folder, the fseventsd daemon creates a new /.fseventsd folder. With deep traversal it takes a while for TM to prepare the new backup but afterwards it should backup all files which are not already in the backup.

  • I tried that, didn't help. I did it even twice, once by booting into single user mode to delete the dir. Also verified that it actually does for a re-scan by seeing related msgs in the system log. – Thomas Tempelmann Jun 30 '14 at 13:23
  • I'm not sure but maybe the TM disk has a /.fseventsd folder, too? I don't know if TM is using the fseventsd on the backup disk as well, if yes then maybe the fseventsd database on the backup disk was corrupted? – GM. Jun 30 '14 at 15:10
  • Tried that as well. No success, either. – Thomas Tempelmann Jun 30 '14 at 17:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .