51

[OS X 10.9.3 (Mavericks)] I've disabled smart quotes in the keyboard settings, but whenever I type ' or " in Messages (old name: iChat), they get converted to and . How do I disable this default conversion?

0

7 Answers 7

58

In addition to System Preferences, this feature can be turned on and off in each app via Edit > Substitutions. Make sure you check that setting as well.

7
  • 1
    In addition to System Preferences I have no idea what this controls, TextEdit? :P
    – Cilan
    Commented Jun 28, 2014 at 21:32
  • Sorry, I can't understand your question. Commented Jun 29, 2014 at 15:46
  • 1
    Don't worry, it was rhetoricle. Anyway, you cannot disable it on messages using system preferences.
    – Cilan
    Commented Jun 29, 2014 at 15:59
  • 1
    Right, but you CAN using the Substitutions menu, and it worked for me. Fantastic! It's suboptimal that I will have to toggle that for whenever I am texting my one friend with a dumb phone, but at least I can!
    – krs013
    Commented Jan 19, 2015 at 7:18
  • No idea why the enable this by default... Thanks
    – Chad
    Commented Sep 18, 2019 at 10:24
21

In El Capitan (i.e. 10.11.1), I solved it by changing the Smart Quote settings:

  1. Open Keyboard in System Preferences
  2. Go to Text tab
  3. Change values for "for Double Quotes" and "for Single Quotes" from drop-down selection to use the simple quotes "" rather than ““

That's it. No need to disable or do any other workaround. Hope this helps, as I had this problem with Message app when posting code.

1
  • 1
    Thanks, but this question has been long solved (1 year 4 months). However, this seems like a good alt for el capitan users
    – Cilan
    Commented Oct 29, 2015 at 12:11
18

Unfortunately none of the posted solutions worked for me. I've solved by changing my keyboard layout from:

  • U.S. International - PC

to:

  • U.S.
1
  • Solved for me! You saved a lot of nervous cells of mine, thank you :) Commented Sep 27, 2023 at 15:22
13

Disable smart quotes:

defaults write NSGlobalDomain NSAutomaticQuoteSubstitutionEnabled -bool false

Disable smart dashes:

defaults write NSGlobalDomain NSAutomaticDashSubstitutionEnabled -bool false

Disable smart quotes for TextEdit:

defaults write com.apple.TextEdit SmartQuotes -bool false

Disable smart dashes for TextEdit:

defaults write com.apple.TextEdit SmartDashes -bool false

13

This shell script disables smart quotes in all applications that currently have preferences files:

for d in $(defaults domains|tr -d ,);do
  osascript -e "app id \"$d\""&>/dev/null||continue
  defaults write $d SmartQuotes -bool false
  # defaults write $d SmartDashes -bool false
  # defaults write $d SmartLinks -bool false
  # defaults write $d SmartCopyPaste -bool false
  # defaults write $d TextReplacement -bool false
  # defaults write $d CheckSpellingWhileTyping -bool false
done

Uncomment the commented out lines to also disable other substitutions or spell checking.

3
  • "all applications that currently have preferences files" - meaning only those where one already made substitution changes?
    – Bondt
    Commented Mar 25, 2015 at 14:19
  • 2
    i'm guessing this is a bash script? would be helpful if you mention how and where this code should be executed. it's potentially very useful but less so without context Commented Mar 9, 2016 at 22:45
  • Edit a plain text file called "diablesq.sh", and paste the text into it. Open a terminal window. Type "sh disablesq.sh"
    – Resuna
    Commented Jan 3, 2020 at 20:27
6

In macOS Ventura (13.2):

  1. Go to System Settings (eg: from the Apple menu)
  2. Select Keyboard in the left navigation
  3. Under Text Input click Edit...
  4. Near the bottom, turn off Use smart quotes and dashes
4

You will find this option in the Keyboard Preferences pane:

  • Open System Preferences.
  • Click on the Keyboard icon.
  • Select the Text tab.
  • Uncheck the Use smart quotes and dashes checkbox.

Note that this is almost a homework question. This is a keyboard/text related setting so it's fairly logical to find it under the Keyboard Preferences.

1
  • 1
    In my question I noted that I've tried this and it didn't work. What I had to do was go under Edit -> Substitutions and disable it there through the app itself.
    – Cilan
    Commented Jun 28, 2014 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .