1

I'm asking for help for my brother! I recently switched over to a dual hard-drive setup, and it worked perfectly. However, my brother is having issues.

First off, here is the hard drive we are trying to put in.

He has an early 2011 15" MacBook Pro. We read up online, and people said that the optical bay for his model only has SATA II, while the main bay has SATA III, which means he should put his HDD in the optical bay, and the SSD in the main bay. He wants to put the HDD in the optical drive area, and then transfer everything over to the new HDD, before putting the SSD into the main bay.

The issue is that when we put the HDD in the optical bay, the computer can basically not recognize or use it. If plug the HDD in via a usb cord, he can initialize it and erase it to Mac OSX Extended (Journaled) perfectly fine. It only takes a few seconds, and as far as I can tell, it works. However, when he actually puts the hard drive in the optical bay, it either doesn't show up in disk utility, or it shows up, but can't be accessed or changed.

We left it in, and it showed up after 30 minutes or so. When he tried to initialize it, however, the computer said it'd take 5 hours to do. The progress bar ended up getting half way done, and then stopping, so that didn't even work.

We thought that maybe it could be a firmware issue after searching on the internet some, but we looked and definitely have the newest firmware version (2.7, I believe). Also, I don't think that issue applies to us, since I think it's only relevant to getting the proper speeds out of a SSD.

We also tried just initializing it before putting it into the computer, but the computer doesn't seem to recognize it correctly. The name is changed from "New HDD" to "disk1s1", and we can't actually access it. That's when we tried initializing it again, just for the progress bar to get stuck.

Looking online, this setup should work. Tons of people have done it, even using the hard drive we are using. We aren't even trying to put a SSD in yet, which is where most people have problems with the 2011 model. This is just a regular hard drive! I don't understand what could be wrong, and could use some help!

If there's anywhere else you think I should post this, just let me know!

Thank you!

0

I believe the issue to be that the controller is still SATA III for the optical bay, yet the connector is a SATA II type, as is the cable. So if you try and place a SATA III enabled drive in the optical bay, it will try and negotiate at SATA III speed (6G). This creates an issue as the cable is not setup for this and the crosstalk, and very low SNR at that speed causes many errors. I got my Seagate Momentus SSHD disk drive working somewhat in the optical bay by wrapping it and the short cable in tin foil, making it a good ground to the chassis, but it still had loads of errors on it. I ended up putting a SATA II disk in which works. My Macbook is a 2012 13in with an 2.9GHz i7 in it. This shows both connectors as 7 series Intel Chipset, both of them are supported for 6G, yet the optical drive is negotiated as 3G (SATA II). My Samsung SSD in the HDD bay, is negotiated as the full 6G.

Have a check in system profiler to see what supported speeds and negotiated speeds you are seeing for your controllers. There seems to be a lot of conflicting information about what model supports what, but it makes sense that the controllers are the same type on the main board for the particular chipset being used. The connectors are different though.

I was hoping there would be a hard disk that you can force SATA II on, or some way of enforcing the controller to only ever negotiate up to 3G, but thus far haven't had any luck :-(

Hope that helps demystify the core issue at stake here somewhat.

  • This actually helps a LOT. What read/write speeds should we be getting from SATA II and SATA III SSD's respectively? We downloaded the AJA System Test, and found that I'm getting about 250 Mbps for each on my SATA II setup, and he's gettin gabout 450 - 500 Mbps on his SATA III (if it's working right) setup. – TheTreeMan Jun 30 '14 at 19:07
0

Firstly, it does not seem to really matter whether you use the Sata II or III port. For most usages you won't see the difference, cf this post for details: http://www.tomshardware.com/forum/280002-32-sata-sata-practical-difference.

Given that the disk shows up fine via a USB interface it means that it's not at fault so it could actually be due to the connector in the optical bay which is a bit worn out or that the drive is not correctly plugged.

Try putting the HD in the original HD bay and the SSD in the optical bay and see if the SSD has the same issue. If it has then the issue lies with the optical bay itself.

You could also put the optical disk back into the bay and see if it works normally or has issues as well.

If the issue seems to stem from the optical bay then you should bring the computer to a shop which can diagnose exactly what hardware issue is causing this.

  • It ended up being the original hard drive. It was dying. I'm not sure why it caused these issues, but after replacing the original hard drive, everything worked perfectly! I was under the impression the SSD wouldn't work in the optibay in the 2011 models, but for some reason, it works perfectly in his computer in the optibay. Oh well! All of our issues seem to have ironed themselves out! Thank you for helping! – TheTreeMan Jun 30 '14 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .