3

This has happened to me a couple of times now. I try to connect to a computer using screen share and for some reason the computer doesn't answer. I'm not worried about that though.

The issue I'm having is that the failed screen share can't be cancelled and doesn't seem to appear in the Force Quit dialog. I've checked the Activity Monitor for all processes with screen in the name, nope. I've checked processes that are using CPU, nothing that looks like a screen sharing. Finally I checked little snitch for network activity and the only thing I saw to the machine in question was check_afp...

Anyway, here's a screen shot that probably doesn't show anything helpful.

Force Quit and Screen Sharing

Thanks in advance for any advice :-) I'm using Mac OS X 10.6.7 on a 2011 MBP.

  • try sudo killall AppleVNCServer, it might work – user6124 May 7 '11 at 2:33
  • I tried, no luck. It respawns the process, but doesn't close the screen share. – Bennett Dill May 7 '11 at 3:01
5

Try force-quitting NetAuthAgent. It won't show up in the regular Force Quit dialog, so use either Activity Monitor or killall NetAuthAgent in Terminal.

  • This worked like a champ! Thanks :-) I was worried about doing this with a file transfer in progress, but it was unaffected :-D – Bennett Dill May 7 '11 at 3:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .