2

I'm currently trying to update my mid 2009 Macbook Pro to Mac OS X Mavericks. I've downloaded the file from App Store several times the but every time when the Install progress reaches about "1 second left" a message pops up saying that the download might be corrupt or that the program can't be verified.

I already tried the following things:

  • Check HDD (also at boot with Cmd + R)
  • Check that apps are compatible to work with Mavericks
  • Checked HDD size (about 40 GB left)
  • Downloaded from different internet accesses
  • Made all offered updates mentioned in App Store

My drive is FileVault encrypted.

It's enough to drive one to despair.

  • Is your Firmware up to date (since you have a older computer) support.apple.com/kb/HT1237 – Ruskes Jun 26 '14 at 12:44
  • The EFI boot ROM version is outdated. But when clicking the link I'm getting an Apple error page (support.apple.com/downloads/…) / MBP55.00AC.B03 (EFI 1.7) – thedom Jun 26 '14 at 12:56
  • 1
    suckers, they should fix they links, try this support.apple.com/kb/DL853 – Ruskes Jun 26 '14 at 13:05
  • Thanks - funny altough: now he's saying I don't need this update... Is there a conrete way to find out what's the problem installing the update. Isn't there a logfile which is logging the actions while update? – thedom Jun 26 '14 at 13:08
  • sorry, I am not aware of that, and since you are getting a generic error, there is no way to know what is doing it. – Ruskes Jun 26 '14 at 13:42
0

Try changing the date to current date in terminal. You can follow Jonathan Mohar's advice.

|improve this answer|||||
  • Tried that like described in the advice. Apart from the fact that date and time are set in the running system. – thedom Jun 26 '14 at 11:51
0

Don't ask me why - but after downloading it the fourth time the installation process went fine. Without any error messages or warnings or whatever.

What's different to the moment when asking the question and the moment where the installation went fine:

  • FileVault disabled.
  • Logged out and logged in again to App Store before redownloading the update the fourth time.

I didn't check the md5 sums of the files...

Thanks for your support - especially @Buskar :-)!

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .