15

The file won't open, with QuickTime, with the following error message:

Item "file.mov" is used by Mac OS X and cannot be opened.

Tried selecting repair disk on disk utility, didn't work.

I'm under OS X 10.7.5.

1
  • Your external disk is a Windows NT file System ?
    – Ruskes
    Jun 25, 2014 at 23:13

6 Answers 6

37

This is a common issue which happens when the file's type and creator attributes are modified by Finder when its writing files, if these attributes aren't restored back to the original values by Finder at the end of its write action, those files won't be accessible to the user.

Running this command will remove the creator and type attributes set by Finder,

SetFile -c "" -t "" path/to/file.mov

Note: If the above command is not found, try installing Xcode command line tool and try the above command again,

xcode-select --install
7
  • 2
    This works a treat. For those looking for the path to the drive, it is in /Volumes/<name_of_drive>
    – MikeyN0
    Dec 23, 2018 at 4:40
  • @Nagendra Rao, every time I reconnect my harddrive this problem occurs again. any way to permanently resolve this? Jul 25, 2020 at 3:09
  • @pkgajulapalli What filesystem is your external hdd? Try reformatting it to latest filesystem (after keeping a backup of course) Jul 27, 2020 at 11:35
  • 1
    @NagendraRao Did anyone ever tell you how heroic you are?
    – StackedQ
    Sep 16, 2020 at 18:25
  • 1
    @StackedQ :) glad it solved your issue! Sep 17, 2020 at 19:40
4

First, a simple workaround:

Drag and drop the greyed movie file to QuickTime Player, or VLC etc. For some reason it works if you do it that way. (at least on Yosemite)

Partial solution:

If you need to copy affected files, or you simply want to "ungrey" them and work with them as usual (double click to open etc) then delete the FinderInfo metadata from the file with this command:

xattr -d com.apple.FinderInfo file.mov

You can see the metadata with:

ls -l@

Unfortunately, for me the FinderInfo metadata (and consequently grey files) reappear every time I remount the ntfs disk on which I copied files using native OS X NTFS write support enabled through fstab. So until someone finds a lasting solution the workaround happens to be quite useful.

It's interesting that files residing in the same directory but copied from a windows machine never get metadata.

2

You won't be able to run Repair Disk on a Windows NTFS filesystem, and NTFS volumes cannot be indexed by Spotlight unless Paragon NTFS or Tuxera NTFS have been installed because Spotlight needs to write its index files to the volume.

I suggest you move these movie files to an HFS+ volume, either to the local HD, or to an external HD formatted with HFS+. You may be able to play the movies with Paragon NTFS or Tuxera NTFS installed, but it may be easier just to transfer the file to a Mac filesystem. If you want to edit these files, you will need to transfer them.

2

I don't have enough reputation to comment, but adding to the great answers above, I navigated to the drive and used a command listed above to clear out the finder info that was added:

cd /Volumes/[drive name]
xattr -d com.apple.FinderInfo *

and then had to tell spotlight not to index that drive (NTFS formatted drive).

This was a good resource — http://osxdaily.com/2012/01/24/stop-spotlight-from-indexing-time-machine-backup-volumes-external-drives/

1
  • 1
    This works for me once, but then every time I want to reconnect my drive it stops working and then my volume is already removed from spotlight preferences.
    – Benno
    Jan 8, 2018 at 7:56
2

Some optimization on the problem:

  1. On terminal enter:

    cd /Volumes/DriveName
    
    SetFile -c "" -t "" */*
    
  2. The last command can be arranged as script running automatically on disc mounting. Use you search engine on that.

1

maybe spotlight was indexing the disk.

also it may be a problem caused by the no mac filesystem.

do the movies work as expected if you connect the harddrive to a PC?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .