5

I'm exporting my photos to my computer by connecting my iPhone 5S (iOS 7.1.1) to my Ubuntu 14.04 setup and cutting the photos from the DCIM folder and pasting them on my computer.
The photos go through alright, but the camera roll still shows the thumbnails. When I click on the thumbnail I get a white blank screen.
How come?
How can I move photos out of the phone without keeping its thumbnail in the camera roll?

3

A hacky and maybe risky workaround which worked for me was suggested here:

  • Go to PhotoData folder
  • Delete Photos.sqlite
  • Restart the iPhone
  • 1
    I'd definitely appreciate another answer which explains why this happens and that offers a non-hacky-risky solution – Jonathan Jun 26 '14 at 10:34
  • worked perfectly on my iPhone4. – Gab Jun 19 '15 at 10:30
2

Why is this happening: because deleting the picture from DCIM has no effect on the database listing the pictures neither to the thumbnails generated during the capture of the picture. Once the DCIM empty the DB points to void placeholders.

How to do otherwise: try rebooting the iPhone. Next time delete them form the device or use some 3rd party softs.

  • Reboot doesn't work. Deleting them 1 by 1 from the iphone UI is just impossibly long... – Pacerier Aug 21 '17 at 20:33
1

Well, I did that, too, deleting Photos.sqlite file. But then when I wanted to look at the thumbnails in the Camera Roll (accessed through running the Camera app) - nothing was there, and it said "Rebuilding Thumbnails" or something, and it took a while. And then all the thumbnails were there. Except one: I couldn't see a thumbnail of a photo I took while this "rebuilding process" was going on. (However, it is there in the Photos app.)

Now, that this process is complete it seems that the new photos result in new thumbnails. And I see them appear in the /private/var/mobile/Media/PhotoData/Thumbnails/ folder.

Also, just as an aside, deleting Photos.sqlite doesn't delete all the old thumbnails. And while they are small, they do end up taking some space on the iPhone storage unit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .