0

I have a small CAT-6 ethernet network featuring a Cisco 18-port switch and an Asus router acting as DHCP server.

Various devices connected to the switch (e.g. printer, NAS) connect to the DHCP server successfully to receive addresses in the 192.168.1.* range. My Macbook Pro and Mac mini also connect over wifi to the router to receive DHCP addresses in the same range.

The Macbook and the Mac Mini (both latest Mavericks) fail to connect via the switch when using ethernet and end up with self-assigned 169...* addresses. With the Macbook Pro I've tried this with three different USB to ethernet dongles, including an Apple model. Setting the ethernet parameters manually doesn't seem to help access the switch either.

This makes me think there's some configuration with ethernet under Mavericks that doesn't match my setup with the 192.168.1.* range? I'm assuming the Cisco switch is not the problem as other devices seem to connect through it fine.

Can someone give me a hint as how to work out what's going on? Does Mavericks always try and look for DHCP servers in the 10.0.0.* range instead?

Thanks,

Stu

  • If you connect a PC to the same cable the MacBook or Mac Mini is plugged in now, does it receive an IP via DHCP? – Kevin Grabher Jun 25 '14 at 8:14
  • I don't have a PC handy but I have used the same cables to connect a Synology NAS (two LAN ports) and both receive IP's via DHCP. I'm starting to think there must be something going on with the way Apple ethernet drivers and the Cisco switch ports negotiate their ethernet speeds and setup. If that process failed that would explain the self-assigned IP addresses? – stu002 Jun 26 '14 at 3:01
  • The last post on hear seems to suggest it's a known cisco bug: discussions.apple.com/thread/1285483?start=45&tstart=0 ; is there a software update for your cisco device(s) by any chance? – Kevin Grabher Jun 27 '14 at 7:59
  • Yes--I've had some success with an AX88179 USB ethernet by setting the switch ports to manual and ditto for the Mac ethernet hardware settings. The connection is lost for a while on wake from sleep though. Still trying to get the Mac mini ethernet to connect at all at various manually set speeds. I believe the Cisco switch is at the last patch level but will double check. Every other device I've connected to the switch has worked as expected though. – stu002 Jun 27 '14 at 9:02
2

I'll answer and accept this question as I'm certain now that the problem is the interaction between modern Macs and my Cisco switch. I can kind of fix the problem by:

  • Setting the Mac ethernet "hardware" tab to manual 1000T/full duplex

  • Setting corresponding switch ports to 1000T/full duplex

  • Turning off the switch green ethernet facility

  • Making sure switch is at the latest firmware release

This seems to work well until the Mac sleeps, then the connection is lost again. I'm still trying to work out how to work around that issue.

1
  1. Open a Terminal window
  2. type cd /Library/Preferences/System\ Configuration
  3. type open .
  4. Find the NetworkInterfaces.plist
  5. Trash it
  6. Restart your computer
  7. Go to Network and it will automatically find your wired connection
  • Thanks for adding that procedure--it will be useful into the future I can see. FWIW: I changed to an HP switch and all these problems went away. – stu002 Jan 22 '16 at 0:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .