2

I am not able to download any app from the App Store on my iPhone 5 which is running iOS 7.1.1.

I have been getting the following error since last week when attempting to download an app.

  • Can you log into the Store via iTunes on a computer? – nohillside Jun 22 '14 at 11:14
  • IMO not a duplicate of apple.stackexchange.com/questions/102935/… as the error message is different—could indicate other reason for error – grg Jun 22 '14 at 13:42
  • @patrix Yes I can. – Amol Jun 22 '14 at 17:23
  • @GeorgeGarside Yes may be. – Amol Jun 22 '14 at 17:41
2

Luckily, I could fix my issue.

I had to change my DNS to 8.8.8.8. My internet used to work before this but after changing my DNS now I am able to download apps from App Store.

But I tell I haven't changed any setting on my iPad 2 running iOS 6 still every thing works including App Store downloads. I think this issue is with iPhone 5 or definitely iOS 7.1.1.

1

This could also be a problem with the AppleID. A friend of mine had this problem that all of the devices registered to his account would not be able to download apps (even when another Apple ID is entered). Only help was to contact AppleCare (you can do that via the support tab on the apple website)

  • I think it has nothing to do with the AppleID as I have been using the same AppleID since 1 year and I have not faced any issue as this one till last week. – Amol Jun 23 '14 at 5:15
0

You can try to restart the device.
If this doesn't help, make a soft reset (you won't lose data). To make a soft reset, press the on/off button at the top and the home button until the apple icon appears (Ignore the "Slide to power off") button if it appears.
If this doesn't help, I would go to the Genius Bar

  • Thank you. I appreciate your help. But I have tried all you just mentioned. I have even restored my iPhone still the issue remains. – Amol Jun 22 '14 at 17:19
  • @Amol Habe you restored it to a backup or have you restored it as a new iPhone? – 130e13a Jun 22 '14 at 19:36
  • Actually I have tried both. Earlier I restored as new iPhone then I found that it did not rectify my issue so I have restored to backup. – Amol Jun 23 '14 at 5:09
  • @Amol did you go to the Genius Bar? – 130e13a Jun 23 '14 at 14:14
  • No. One of my friends helped me. – Amol Jun 23 '14 at 14:26
0

i was getting same error though i can access the net and wacth videos online, infact the speed i great ranging 5mbps up,. i tried changing my dns to 4.2.2.2 and it worked right away.

-4

It is not a DNS issue. U should change the date to previous dates than ur current one and ur application will install normally. I don't know why, could be a buy in IOS

  • Right now your answer is flagged as "low-quality", add some meat to it to prevent deletion. – Ruskes Sep 16 '14 at 19:15

You must log in to answer this question.

protected by Community Sep 18 '14 at 9:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .