9

My screensaver pictures have quotes and sayings and the three or so seconds of transition between pictures that is built into the OS X Mavericks is far too short a duration to read the quotes and sayings. How can I slow the change rate to about 30 seconds per slide?

6

Previous answer still works, and also for Yosemite/El Capitan/Sierra with the caveat that System Integrity Protection (SIP) now needs to be disabled first.

  1. Verify current slide duration:

    sudo /usr/libexec/PlistBuddy -c "print ':JustASlide:mainDuration'" /System/Library/PrivateFrameworks/Slideshows.framework/Versions/A/Resources/Content/EffectDescriptions.plist
    

    The system default is 3.

  2. Reboot and hold Cmd+R to go into recovery. In the menu select Utilities > Terminal and disable SIP with the following command:

    csrutil disable
    
  3. Reboot again and set slide duration to the desired value in seconds:

    sudo /usr/libexec/PlistBuddy -c "set ':JustASlide:mainDuration' 10" /System/Library/PrivateFrameworks/Slideshows.framework/Versions/A/Resources/Content/EffectDescriptions.plist
    
  4. Reboot one more time into recovery (Cmd+R) and reenable SIP for good measure

    csrutil enable
    
4

First check your current duration setting (usually it is set for 3 seconds)

Paste this in your Terminal (and provide password)

 sudo /usr/libexec/PlistBuddy -c "print ':JustASlide:mainDuration'" /System/Library/PrivateFrameworks/Slideshows.framework/Versions/A/Resources/Content/EffectDescriptions.plist

It will show you the current number in seconds, mine shows 3.

Next: paste following in to your Terminal to change it to let say 10 seconds (or any number you like).

sudo /usr/libexec/PlistBuddy -c "set ':JustASlide:mainDuration' 10" /System/Library/PrivateFrameworks/Slideshows.framework/Versions/A/Resources/Content/EffectDescriptions.plist

SOURCE: http://hints.macworld.com/article.php?story=20130215183522445

Edit: This solution no longer works as of August 9, 2016. The time setting is readable, but is no longer settable by the terminal command.

  • Worked great, thanks. If you look at the preview it seems to not work - still switches photo every 3 seconds - but when activated, the screen saver takes your 10 second interval. Using Yoesmite. – fazy Jan 26 '16 at 13:13

You must log in to answer this question.

protected by Community Nov 18 '16 at 19:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .