51

Whenever I bring a video to fullscreen on YouTube (on Chrome or Safari), the video will go to fullscreen but the dock and menu bar remain visible, covering the top and bottom parts of the video. They used to be hidden when I went to fullscreen, so I don't know what happened. How do I fix this?

9
  • Go to the Apple menu, and from the Dock submenu select "Turn Hiding On".
    – Ruskes
    Commented Jun 21, 2014 at 17:58
  • 1
    I'd like the Dock to only hide when I'm in fullscreen mode though. Also that doesn't fix the menu bar issue. Commented Jun 22, 2014 at 18:40
  • 1
    Like I said, this used to be what happened before when going full screen, but it doesn't happen anymore. Commented Jun 24, 2014 at 19:11
  • I am seeing the same problem. Commented Aug 7, 2014 at 4:52
  • 1
    i saw similar behavior on archive.org. i believe it was the difference between flash and some other delivery method (html 5?). not sure how to test this immediately. Commented Sep 23, 2014 at 15:44

8 Answers 8

104

If none of that works, open Terminal and enter killall Dock.

8
  • Good solution! Got a 1 up Commented Apr 6, 2015 at 3:01
  • This is the best solution I've found
    – DanMcQ
    Commented Jul 23, 2015 at 21:07
  • Did not work for me.. chrome bookmarkbar still visible :/
    – IcEBnd
    Commented Jun 3, 2016 at 8:09
  • 3
    This worked for me! But what did that do?
    – LampShade
    Commented Sep 18, 2016 at 3:25
  • 2
    @LampShade: This force kills the process, like how you kill from Activity Monitor. Since, this is a crucial part of OS, iOS will restart it. Think of doing a reset to a good state(from buggy one). Commented Dec 15, 2016 at 16:34
16

I have this same problem with YouTube, Netflix, mPlayerX and VLC, where the Dock stays visible (on-top) after making the video go full screen.

This problem can be fixed by going into System Preferences...Mission Control and turning off the option "Displays have separate spaces." You have to logout after making this change.

Turn off displays have separate spaces

2
  • 1
    This is wrong answer! What if I need separate spaces in my displays?
    – WebBrother
    Commented Oct 7, 2018 at 17:50
  • 1
    You're missing the point....we all agree that it should work correctly and this should not be necessary. If you do this temporarily, it will work. Imagine my frustration when I first had this issue and had no solution at all...it just didn't work and there were no work-arounds.
    – flakshack
    Commented Nov 2, 2018 at 23:17
3

If you make the browser fullscreen before making the video fullscreen, this problem should disappear.

2
  • I made browser go fullscreen and then back to normal state. After doing this, dock disappeared when video goes fullscreen. Thanks!
    – rzaaeeff
    Commented Feb 7, 2020 at 12:21
  • it's a workaround, but it's the only that works. even in 2022 on Moneterey this is the only way i've seen osx actually work "correctly". separate monitors will keep the menu bar when a browser video is full screen only if the green-button full screen is clicked on the browser window first
    – worc
    Commented Jul 12, 2022 at 21:37
1

I had the same issue and I find it. This has to do with multiple monitors and mirroring (I connect my tv on the mac). Turn "Display mirroring" to off. That's it!

1

For me this works:

First switch Chrome window mode to full screen mode by pressing the green dot on the top left side of the view:

chrome full screen mode green dot

After that menu bar should be hidden so now enter full screen mode in youtube player:

youtube full screen mode

Enjoy your video on full screen without menu bar.

1

One workaround for this is to change Dock positioning to somewhere else and putting it back to your preferred position. You can do this under Dock & Menu Bar section of System Preferences.

Dock Position System Preferences

1
  • this worked for me!
    – dlporter98
    Commented Dec 17, 2021 at 4:00
1

In my case, I discovered the source of this issue was the setting Automatically show and hide the menu bar being set to Always. By setting it to In Full Screen Only, the issue was resolved.

Screenshot of the Control Centre settings for 'Menu Bar Only' showing the 'Automatically hide and show the menu bar' option set to 'In Full Screen Only'

0

For me I had to use /Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --app="http://youtube.com" to have it work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .