33

For two days my Mac has been "dead"; the hard drive crashed, so I reformatted (twice). I wanted to reinstall Mavericks via Recovery, but at the end of the process it shows nearly 1 million minutes remaining and the process stops. I thought it was the hard drive that was dead but the Windows (BootCamp) part works very well.

I wanted to make a bootable USB of it (Using MacBook Air which is running OS X Mavericks GM), but when I tried to run the command for copying the files from .app to USB I got the following error:

Erasing Disk:
0%... 10%...
Error erasing disk error number (-69888, 0)
A error occurred erasing the disk. 
2
  • So you have actually a question about how to create a bootable USB via your Macbook Air?
    – Rob
    Jun 21, 2014 at 11:10
  • @Rob Yes, because in this way perhaps I can solve my first problem.
    – TTL
    Jun 21, 2014 at 11:41

13 Answers 13

61

The solution may be actually easier than you think!

If you get Error erasing disk error number (-69888, 0) A error occurred erasing the disk. message when trying to create a bootable USB, make sure the USB drive is not currently used by the system or your apps (think open Finder windows or current directory in Terminal).

5
  • 13
    I think this should be the accepted answer. I had opened it in another Terminal window. Closed it and the error disappeared!
    – kissgyorgy
    Oct 6, 2015 at 0:45
  • I had the exact same problem in the OP, and it persisted even after I closed all open windows and terminals that possibly had the drive open. However, after rebooting the machine, the problem went away, suggesting that there was some "invisible" connection still left after I closed all the visible windows.
    – xdavidliu
    May 18, 2018 at 23:26
  • close all finder windows before creating the bootable flash disk. When one is open it automatically displays mounted drives like the flash, which locks them for some operations.
    – pferrel
    Jun 28, 2018 at 18:40
  • 1
    For me it was iStats Menu. It was probably keeping an eye on the USB drive, a little too closely... Force quiting it with Activity Monitor did the trick as I couldn't work out how to shut it. Nov 11, 2020 at 23:48
  • @kissgyorgy Strange question, but are you related to Anna Gyorgy who wrote a book called "No Nukes": books.google.com/books/about/No_Nukes.html?id=JILbAAAAMAAJ
    – ATL_DEV
    Jan 8, 2022 at 18:45
11

Open terminal and use

sudo killall Finder

Shuts down all the weird stuff in the background.

Good luck.

9

Erasing Disk: 0%... 10%... Error erasing disk error number (-69888, 0) A error occurred erasing the disk

This error will occur if the usb stick and the main drive have the same name - typically: Untitled

The instructions for creating an OS X usb installation stick typically suggest that the usb stick should be called Untitled. But that would also be the default name of the main drive if it has been reformatted. The solution is to name the usb stick something else and change the command to reflect the new name.

You can check for a name clash in terminal:

cd /Volumes
ls

If there is a Volume called Untitled and another called Untitled 1 then the error is occurring because the command you have issued is trying to erase the main drive and not the usb stick.

1
  • Ohh my gaaaad, how can this even be a problem (Note this also include upperCase letters in the drive name) Feb 13, 2019 at 8:40
6

Change the volume Name. The worked for me!

2
  • This worked for me when trying to create a Mojave installer while running the Catalina beta
    – lidsinker
    Sep 3, 2019 at 17:08
  • I don't know why but this answer fix the issue when I'm creating a Big Sur Installer USB. I changed from Untitled to other name then everything is fixed.
    – Harry T.
    Mar 21, 2022 at 15:36
4

What I did was to name the thumb drive “123” then to the terminal window I just renamed “Untitled” to “123” then it resolves the issue.

2

For me, this worked, and got rid of the -69888 error :

  • click the eject icon for the USB drive in Finder
  • click Force Eject, if prompted
  • physically remove the USB drive from my Macbook Pro
  • plug the USB back in again
  • immediately run the createinstallmedia in Terminal
2

My problem and solution: You can't create a bootable disk if your external drive is in APFS Volume format. Try right clicking your volume in Disk Utility, and Delete APFS Volume. Reformat as Mac OS Extended (Journaled).

1
  • works like a charm (mac OS Monterey 12.0.1)
    – a_girl
    Nov 3, 2021 at 9:07
2

I had the same problem with the macOS Monterey createinstallmedia script. The accepted answer "make sure the USB drive is not currently used by the system or your apps" is correct, though in my case, I had to dig a little deeper.

In addition to the "Error erasing disk" message, my USB flash drive would not eject/unmount. Sometimes Finder would hang when trying to eject, sometimes there would be a message about some program using the drive.

To find out which application is using the drive, use the following command in Terminal sudo lsof +D "/Volumes/[name of drive]". In my case, it was mds and mds_stores, which are related to Spotlight indexing.

I have no idea why Spotlight would want to index a removable device, but you can disable it in System Preferences -> Spotlight -> Privacy. Just drag the /Volumes/[name] folder from Finder into the box. After that and a restart, I was able to create the install media.

If that doesn't work, you could try the following commands in Terminal (source: https://forums.macrumors.com/threads/how-to-avoid-spotlight-to-read-write-to-an-external-drive.2333529/)

mdutil -i off -d /Volumes/[name]/
rm -r /Volumes/[name]/.Spotlight-V100/Store-V2/
1

I solved it renaming my USB cause it had the same name as the Hard Drive where the operating system was running. After that it worked perfect.

0

We are dealing with 2 different problems.

To create a bootable USB you will need a Mavericks Installer package from Apple Store the 5.5 Gig file saved to MBA- but not run.

I used this proces to make a bootable USB:

Bootable USB Format it, using Disk Utility, as a Mac OS Extended (Journaled) drive, named Mavericks. This can be done from the Erase tab within the app; make sure the USB drive does not have multiple partitions (that can happen, so turn to the Partition tab to verify and correct this).

Open Terminal.

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Mavericks --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --no interaction.

Erasing Disk: 0%... 10%... 20%... 30%...100%...

Copying installer files to disk…(this part can take 30 minutes)

Copy complete.

Making disk bootable...

Copying boot files...

Copy complete.

Done.

If problems reoccurs get another USB stick with minimum of 8 Gig capacity (not partitioned).

  • Second problem:

Repairing your Hard drive:

If the MBP boots in the Recovery mode using cmd-r then follow that process to restore your OS installation, or use the Disk Utility to check/repair the disk.

You can open the terminal and use the fsck -fy to check repair the disk.

If the problem is minor you can start in Safe mode that will correct some minor issues.

2
  • Thanks, I tried to use Disk Utility to format my Hard drive but when I check the disk it is said that my disk must be repaired but it doesn't work too.
    – TTL
    Jun 21, 2014 at 11:37
  • In that case you can try the fsck -fy as your last resort.
    – Ruskes
    Jun 21, 2014 at 11:43
0

The problem in our case was a space after /Volumes/ in the command. That occurred when we copied the command from a website.

So check for spaces if you copied the command!

0

For me what worked is to go to disk utility and select "Show all devices". The default is to show logical volumes. Then clean the actual device, get it's name, and run createinstallmedia again.

0

I kept getting the error message, so I changed my USB disk name to Untitled and followed Artie Leechs instructions. Worked like a charm!

For me, this worked, and got rid of the -69888 error :

click the eject icon for the USB drive in Finder click Force Eject, if prompted physically remove the USB drive from my Macbook Pro plug the USB back in again immediately run the createinstallmedia in Terminal

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .