3

I've just bought a new rMBP 15 inch a few days ago and for some reason every time it goes into sleep / powernap mode, when I turn it back on the wifi doesn't work. The odd part is the wifi still appears to be connected but I can't transfer any data, go online etc. I have to turn wifi off and on in order to get back online.

Any ideas what's going on? I have Mavericks installed and completely up to date.

  • Little bit more information could help. What are you connecting to, model, make, protocol ect..I have that problem sometimes, the WiFi icon shows connected, but it is not, when checked in Terminal. – Ruskes Jun 21 '14 at 7:07
  • @Buscar웃 the router is a Thomson TG585v8 – JamiePatt Jun 21 '14 at 12:48
1

I have exactly the same issue on my rMBP, but only with my home router. Every other router works fine, so I've put it down to the router being strange (it's a proprietary ISP router) as opposed to the Mac.

  • It's odd because I have two other macs that are fine with it... – JamiePatt Jun 21 '14 at 12:30
  • @InfluenceJamie What version of OS X are you using? – grg Jun 21 '14 at 12:35
  • Check the original question, Mavericks fully up to date. – JamiePatt Jun 21 '14 at 12:42
  • @InfluenceJamie Apologies, I meant the other Macs – grg Jun 21 '14 at 12:48
  • I have an older core 2 duo macbook pro and a 5,1 Mac Pro both running Mavericks as well... haven't had this problem ever before running all the way back to Snow Leopard. – JamiePatt Jun 21 '14 at 12:50
0

One potential solution is that you may have static IP or DNS addresses in your WiFi setup. For me, I encountered the problem with my new rMBP when I was trying to go online outside the home (at a car shop, as it was). I had a valid network connection, but zero internet capability. It was quite frustrating.

As it turned out, when I migrated my settings from my MBA, the static IP and DNS addresses in that machine transferred over. I had not used the MBA outside my home, and it had been set up that way because my previous ISP provided router did not play nicely with Apple products.

Once I changed back to automatically assigning DHCP, the problem was resolved. I think I also had to clear a static DNS entry.

I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .