3

I was removing a wifi network and after removing it, my wifi icon is blank, showing a cross over it, while i hover over it which says Not Configured, I googled the problem but didn't find any solution to the problem, I tried reinstalling mavericks, while everything (user, setting and everything remain same) the problem remain same too. What can be the problem? How can I fix it? wifi info and network info

4
  • Go to about my mac => more info => system report => Network => WiFi and post a print screen Jun 20 '14 at 11:40
  • @Thomas I edited the question and posted a screenshot, not on PC but from mobile
    – localhost
    Jun 20 '14 at 11:46
  • Thanks, could you also provide one with about my mac => more info => system report => Network ? Jun 20 '14 at 12:15
  • @Thomas I updated it
    – localhost
    Jun 20 '14 at 12:19
5

Rather than removing a Wi-Fi network, it appears you've removed the Wi-Fi service. In OS X prior to 10.10, this means the AirPort shows Not Configured.

To allow configuration of AirPort, you need to add the Wi-Fi service back to the list of services:

  1. Go to System Preferences → Network and click the + button to add a service.

  2. Select Wi-Fi as the Interface and provide a service name.

This will allow configuration through the menu bar item.

3
  • @Georhe Garside it worked, thanks mate. Should I delete the screenshots from question as it MAC address?
    – localhost
    Jun 21 '14 at 4:12
  • @Nofel No problem! You can if you want; it'll still be in the question's revision history though. Flag for a moderator if you want an older revision deleting.
    – grg
    Jun 21 '14 at 6:29
  • @grgarside It works well for macOS Sierra! Thanks a lot.
    – Mannopson
    Jul 25 '17 at 1:30
0

As even after installation, your hardware is not functioning, then it certainly HS. Do an Apple Hardware Test in advance mode (could take time)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .