2

I have two accounts that are hosted by Gmail. One is my personal account with a gmail domain, the other is a work account with our company's domain.

When I send or reply to mail from my Mac using Apple's Mail.app, replies to those messages always go to my personal account.

I looked in the obvious places - Accounts and Preferences. The only thing that seemed related was under the Composing preference, which was set to "send new messages from account to selected mailbox", which I think is the right one.

Can anyone offer some insight?

2

Ah, so this turns out to be a feature interaction issue.

Gmail always sends mail out with the address of the login of the SMTP account that sent it.

Mail will try multiple SMTP servers to send a mail if the first one fails.

So what was happening is that the settings for the SMTP on the work account were wrong, and the login failed. Mail silently failed over to the next server on the list, my home account. That login used my home address, so Gmail silently changed the name on the message.

Interesting.

0

Make sure it's not a error from the sender, and then contact Google. The recipient maybe replying from an ongoing conversation in which you started with your personal email and then continued with your work email, or the sender has both your work and your personal email in their contacts list and has designated your personal email as a default. There's nothing in Mac Mail that could cause this as long as you have the correct mail settings which Google would be best to provide.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .