2

New Mac/OSX user here. Thanks to google I've come up with this automator script:

on run {input, parameters}

    tell application "Finder"
        activate
        make new Finder window to home
    end tell

    # return input
end run

I saved this as ~/Library/Services/New Finder Window Home.workflow.

In System Preferences/Keyboard/Shortcuts/Services/General/New Finder Window Home I assigned it a new shortcut key ALT+CMD+e. It's supposed to mimic Win+e key on Windows.

On every application I see this script in the top menu in <App name>/Services/New Finder Window Home and pressing that combination works.

Except in Finder itself

In Finder itself, this script does nothing. I would like to behave it the same way as everywhere else: just open me my home directory.

Solution thanks to Thomas

It seems I need to assigned this to the Service and as part of the App Shortcuts with the same shortcut (would be great if someone could explain that too).

1

Go in System Preferences/Keyboard/Shortcuts/AppShortcut then add a shortcut for finder with the desired menu name (Home I think) and put your keybidding alt+cmd+e and voilà

1

Hey man I found this thread after searching how to do this exact thing. I figured it out and thought I'd post it here for any who might be having the same trouble. I am running 10.10.2 btw.

The solution is to have the service receiving 'no input'. That way you can just hit the shortcut and it won't be waiting for something to process, which was causing it to not do anything.

Once you save this, go back to System Preferences/Keyboard/Shortcuts. Navigate to Services and scroll to the bottom. You should see the service in a category called General. Assign a shortcut and it should now work.

This is what your AppleScript should look like

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .