I have installed OS X Mavericks as a guest on a macbook pro with vmware fusion 6.

To do this, I followed the instructions at the following:

Creating a new OS X virtual machine from the recovery partition in VMware Fusion 6.0 (2056798)

How to install Mavericks in VMware Fusion?

I have installed the vmware tools.

After completing the installation steps I started using the vm and found that the § and ` keys are the wrong way around.

I tried adding two keyboard input sources, US and British, switching between these does not help.

I searched around a little and found the following on the vmware communities

incorrect keyboard mapping in OSX 10.7 guest

This seems to be the problem that I am facing, I could not find any solutions on that page. It is marked with the following

This question is Not Answered.

What do I need to do to get the keyboard on a guest os x mavericks on a macbook pro host respond to the same keys as the host?

1 Answer 1


Go into the VM’s settings (+E), and enter Keyboard & Mouse. You will see various profiles. Select one to use (or leave the one that’s already selected), press the small cog at the bottom of the window, and pick Edit Profile…. Go into the Key Mappings tab where you’ll be able to map keys into other keys. While this won’t correct the keyboard layout on the system, it will at least make so that the correct keys are passed when you’re using it.

  • This requires you to be able to figure out how to produce a particular character keystroke in the client in the first place. On Linux running in VMWare Fusion, I can find no way to insert the | character with a Finnish keyboard.
    – tripleee
    Jun 1, 2023 at 4:48

You must log in to answer this question.