17

I am missing a Developer option under Settings menu. What do I need to do to make it appear?

5

In versions of Xcode prior to Xcode 6, you can connect the device to your computer over USB, open Xcode → Organizer and select Use for Development.

Use for Development was removed from Xcode in Xcode 6 and later. It is no longer possible to do this for devices using Xcode 6 or later, even with the Devices page (⇧⌘2).

  • I see no option "Use for Development" on that screen – Jonah Mar 23 '15 at 1:42
  • Sure. This is what I see after navigating in XCode 6.2 to Window -> Organizer: i.imgur.com/Mw61lob.png – Jonah Mar 23 '15 at 15:56
  • @Jonah Use for Development appears to have been removed alongside the introduction of the new Devices page (accessible through ⇧⌘2). (Sorry for the delay, missed the ping—feel free to ping me in Ask Different Chat as I do miss the occasional comment) – grg Apr 9 '15 at 18:14
  • TotalForge's answer worked for me. – Richard Brightwell May 13 '15 at 2:05
9

I found that by powering off the device, and turning it back on while connected to the machine running Xcode 6.3, the Developer settings menu returned for my iOS 8.3 devices.

  • This is the solution as of May 2015. Tested with iOS 8.3 and XCode 6.3.1 on iPhone 6. – Richard Brightwell May 13 '15 at 2:04
3

Apple removed the device list from Organizer in Xcode 6. Try going to Window->Devices. You should see your attached device in the list and from there you can enable development.

  • How does this improve or differ from other answers? – user151019 Mar 25 '15 at 18:03
  • The OP said he was opening Organizer. Devices are no longer displayed there in xcode. You can find your devices in the devices window. That's the difference. – Matt Smith Mar 25 '15 at 18:07
  • Well explain that and give some idea of versions of Xcode – user151019 Mar 25 '15 at 18:13
  • I made the edit based on your recommendation. – Matt Smith Mar 25 '15 at 18:19
  • 2
    How do you enable development from the Devices window? – GreenAsJade May 14 '15 at 12:11

You must log in to answer this question.

protected by bmike Jan 21 '16 at 21:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .