I recently created two web links using Safari's "Add to Home Screen" and now it seems to be impossible to remove them.

The following has been attempted (from http://www.peachpit.com/articles/article.aspx?p=1395687&seqNum=9):

To remove a Web clip, tap-and-hold for a few seconds on it, until all the icons start to wiggle. You’ll see a little X in the upper-left corner of each Web clip (and app that can be removed). Simply tap the little X and then tap Delete from the dialog that appears. The Web clip will disappear, and your remaining icons will reshuffle. Tap the Home button to stop the icons from wiggling and lock them in place.

That X does not show up on my icons.. I can drag them around, even to other pages, group them in folders and bring them out again, but not delete them.

1 Answer 1


Web clips added by a profile can be set to not be able to be deleted with the X, therefore hiding the X when in edit mode. To remove a web clip added in this way, you need to remove the profile from Settings → General → Profiles.

You can also try disabling restrictions if they are on. Go to Settings → General → Restrictions and switch it off, then try removing the web clips.

  • 2
    I have no profiles, but found restrictions. Settings → General → Restrictions (Disable Restrictions), remove the icons, reenable restrictions is the way to go. Since your suggestion helped me, you can add this to your answer and I'll accept. :p Thanks!
    – LGT
    Commented Jun 18, 2014 at 8:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .