1

I want to share my 4G connection with my laptop since our WiFi connection at home can be slow. However, once I go to the iPhone Settings > Personal Hotspot and enable the hotspot, the iPhone asks me to enable its WiFi antenna.

At this stage, the iPhone automatically connects to my WiFi network at home and I cannot really transfer the 4G connection to the Hotspot.

What should I do (apart from connecting the iPhone via USB to the laptop)?

More importantly, why do I loose the 4G connection and connect to the WiFi network instead of the iPhone being smarter and procuring my 4G connection?

This has happened in the past very rarely and I could always enable 4G iPhone hotspot over WiFi. Now the problem happens each time I accept the prompt to connect to WiFi.

  • Update: after multiple cold resets of my iPhone, the issue has been fixed (it seems permanently). I will update you if it happens again. I still do not know what caused the problem in first place. – jDonMas Jul 8 '14 at 9:45
  • 1
    keep in mind in typical cases wifi is an unmetered connection, and 3G/4g is metered. From the description you give I think it's working correctly which is trying to off load data to the unmetered connection whenever possible. – Tyson Oct 25 '14 at 2:22
1

Try turning off your home WiFi. A kind of interference, maybe?

  • 1
    Indeed, it is some interference between the protocols. It works if I switch off my home Wifi. However, I think that I shouldn't be obliged to turn it off in first place. This sound like a bug on the side of iOS. – jDonMas Jun 17 '14 at 12:59
  • 1
    There are a lot of signals and the spectrum is quite collapsed... I have to deal with a lot of WiFi signals at home and I change my router settings once a week (I change the channel, the signal type -from g to n and vice versa-)... – Eva Thyssen Jun 17 '14 at 13:02
1

Sounds like its auto connecting to the home network - known networks are joined automatically when you turn on your iPhones wifi so you need to click the "i" next to the network name in your iPhones wireless network settings and select "forget this network' to stop that occurring?

  • Thanks, this however, is an even more complicated exercise than the one proposed by Eva. I need to forget my home network each time I use the Hotspot feature. I am sure Apple didn't mean it this way. – jDonMas Jun 17 '14 at 13:39
1

This clearly isn't how the hotspot is designed to work. Have you tested for corrupt preference files on iOS by backing up the device and restoring it as a new device?

At that point, you can test the cellular hotspot without ever joining the home WiFi in the first place and verify the carrier side is working with your hardware. If and only when that works, then connect to WiFi and repeat the test with tethering.

At that point, you will have narrowed down and verified the hardware works and the cellular plan works and the firmware / carrier settings are all set. You can then either set up the phone as you wish or restore the backup knowing the status of the hotspot feature.

  • Hi bmike and thanks for the troubleshooting suggestions. Indeed, hotspot over tethering works fine (i.e. with the WiFi antenna/receiver disabled on the iPhone). So the carrier side is fine. I will back up and restore the iphone and see what that gives. Will update you then. – jDonMas Jun 18 '14 at 10:30
0

Call your cellular contract provider because sometimes they do block the hotspot feature, i.e. if you live in the uk a company called gif gaf allows unlimited data and have not blocked the personal hotspot function on the iPhone, however if you use it they may cancel your contract.

hope that helps

  • The hotspot feature works for me. I've tried it many times. It is just that I can't get it to work at home due to my WiFi interfering. – jDonMas Jun 17 '14 at 13:40
  • ok, then the finally thing i can suggest because there would be no fix for this in the settings menu, i would suggest you go to apple explain the problem have them check your phone and replace it or fix the issue internally. – user3725924 Jun 17 '14 at 13:58
0

(excluding bluetooth) iOS forces you to use WiFi [set to ON] when you turn your hotspot ON. This is super crappy since [in my case] the WiFi picks up the available office wifi connection which blocks a lot of content (like FB). The only way you get around it is forgetting the network, in which case you lose all of your settings...OR use bluetooth. Unfortunately 1) Bluetooth is slow; and 2) if you have a hard [network] connection to your docking station, the Bluetooth connection assumes a lower position...so my laptop still routes through the company network. In other words, I have to take my laptop off the docking station to use bluetooth at all.

Now here's the rub with Apple... I have a 2nd phone with uses the Android OS on a Samsung and with that, I can have the hotspot ON and the wifi turned OFF...thereby allowing my laptop to connect via wifi to my phone but using cellular data instead of the company wifi.

  • How does this answer the question, exactly? – Ian C. Oct 24 '14 at 23:13
  • By stating the fact that none of us can accomplish what the above user wants with an iOS phone...I've tried every which way. Android allows you to switch off wifi independently and force cellular usage; iOS does not. Not everything can be a happy ending. – James N. Oct 31 '14 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .