103

I have switched to macOS recently. The only thing that's disturbing me now is the missing the tilde sign (~). The closest thing I achieved to this sign is the accent tilde (˜). This accent tilde won't work with my current passwords.

I'm using a U.S International PC keyboard layout.

How do I make the tilde sign work on my Mac?

5
  • 1
    What about hardware? Are you using a Mac style keyboard? Or your old PC style keyboard?
    – voices
    Commented Dec 21, 2015 at 11:26
  • 5
    $3000 laptop and it can't handle typing, it can't properly connect to APs, it can't delete char at right, it can't have both function keys and multimedia keys at the same time... I am switching back to PC with Linux Commented Jan 9, 2020 at 17:23
  • 1
    The amount of answers and comments to a question about how to type a single character made me lol so hard! Don't get me wrong, I have a Macbook and two Apple keyboards so I feel your pain.
    – ruslaniv
    Commented Apr 18, 2020 at 9:01
  • For US Keyboard I use Control + ` + Enter Commented Jul 17, 2022 at 20:31
  • The only thing that ended up working for me was rebinding the key using Karabiner-Elements...
    – mrexodia
    Commented Mar 16 at 14:57

12 Answers 12

84

You type the accent tilde (shift `) then space: ~

17
  • 8
    I have to do Option + n to get the little tilde, but Shift + the key under ESC only displays ±. I'm used to the PC formats which do as you suggested (without the extra space), but it's not the case on my Mac.
    – aborted
    Commented Jun 16, 2014 at 0:52
  • 5
    Then it is shift + the key to the left of z. Is ` not marked on that? Commented Jun 16, 2014 at 2:15
  • 12
    Alt + n then space gives me ˜. shift ` gives me ±. Commented Oct 20, 2016 at 9:41
  • 1
    @ThomasAhle You seem to be confusing those keys. Alt and Option are the same key. New window is Command n (⌘ n). Alt/Option n plus space should produce ~. Commented Oct 20, 2016 at 17:04
  • 2
    @FelixCrazzolara Just use the US input source instead of US International PC. Commented Feb 7, 2020 at 17:04
49

You might consider switching "U.S. International PC layout" to "U.S. layout" enter image description here

6
  • There is no need to do that. Commented Jun 16, 2014 at 0:50
  • 14
    I've tried what you said, but even the U.S layout gives me § without shift and ± with a shift press. Suggestions?
    – aborted
    Commented Jun 16, 2014 at 0:56
  • 12
    It's probably on the key that located between Shift and Z. Make sure you have "Show Input menu in the Menu bar" selected, and open Keyboard viewer from the menu bar to see you keyboard.
    – Sergei
    Commented Jun 16, 2014 at 1:04
  • 1
    On MacBook Pro with norwegian keyboard: type Alt+^.. Commented Apr 22, 2015 at 10:23
  • 2
    Thanks, this is great help! I never need an superseced tilde but always need the home symbol. Even in scientific work, I will use \tilde instead
    – IceFire
    Commented Apr 19, 2020 at 7:21
30

On my Czech keyboard when using the U.S. input source it works to use ⇧ Shift+/ (button next to Left Shift, see the screenshot). I believe the same button is above the enter key on MacBooks from other countries.

When using the Czech input source with this keyboard, ~ is gotten via ⌥ Option5 (where it is printed on the key).

MacBook keyboard keyboard preferences

5
  • The question is about the US International PC layout. Plus your answer is already covered by the one from Sergei. Commented Nov 29, 2016 at 20:54
  • 4
    This answer helped
    – Oion Akif
    Commented Dec 4, 2016 at 16:57
  • 2
    You saved me a lot of headaches!
    – Mysterio
    Commented Feb 23, 2020 at 10:50
  • 1
    ~ Only correct answer ~
    – maruf571
    Commented Nov 7, 2022 at 13:29
  • This works for me on macOS Ventura 13.3.1. Thanks.
    – ttt
    Commented May 14, 2023 at 11:03
16

On a French, Spanish or German Mac keyboard, type +N to write the ~ character then space for normal tilde or n for tilde over n.

1
  • 1
    This worked for me in German keyboard on Mac.
    – Rmahajan
    Commented Apr 28, 2022 at 7:45
9

On a Finnish Mac keyboard layout (probably applies to some other international keyboard layouts as well) the tilde can be produced with the key with the symbols . That is on the left side of Enter and below the Backspace key.

When pressing Alt and space the tilde ~ appears.

3
  • Didn't work in Minecraft + Finnish Mac keyboard, unfortunately. Commented Mar 31, 2018 at 16:42
  • 1
    This also applies to the Danish layout.
    – Clearer
    Commented Aug 2, 2018 at 9:13
  • 1
    No space needed, only cmd + ^
    – blub
    Commented Oct 19, 2020 at 13:55
5

For those readers who want to make tilde accents over characters instead of the NORMAL tilde sign (~) requested by Aborted, here is some possibly useful info:

OptionN applies a ~ to the next a, o, or n that you type (given that you release them first). In the event that your keyboard/keyboard settings do not afford you the character, more modified character options are available in the keyboard preferences option available from the toolbar in the upper right corner. keyboardOptionsTab select "Latin" from the option on the left, then double click on your desired character to insert at your cursor. characterOptions Another option is the Accent Menu you get when you hold down the key for the base letter, as described by Apple here

0
5

In the Spanish keyboard, press and hold the ⌥ Option/Alt key and hit "ñ".

4

On my MacBook with Italian keyboard layout it works with ⌥ Option5.

This is tilde as in "~", ASCII 126, that can be used for example in Linux CLI.

⌥ OptionN followed by Space produces the diacritic tilde : "˜"

That looks similar, but it's actually smaller and shifted upwards and is not the tilde ASCII but rather Unicode 0303 combining diacritic tilde https://www.compart.com/en/unicode/U+0303

1

I just pressed all bottons and found that if you press ⌥ Option/Alt + ¨ you will get ~.

1
  • This works on my Danish keyboard layout :) Commented Nov 28, 2019 at 10:19
0

The U.S International PC keyboard layout was the issue for me, as well as similar issues for other symbols (different versions of ^, and auto options for ' and " that I didn't want). Keyboard shortcuts were ineffective with this layout too, always outputting accent hildes. Changing to the Australian keyboard worked for me, and U.S. layout works too. Other types of keyboards should work too, though based from the other answers, the output for hilde (and also for other symbols) varies across different types of keyboards.

-3

Try using Shift+Page Down. I don't know Apple keyboard layout (I'm using a Hackintosh) but it works for me.

-4

Try hold option key down and type n release option key and type n again ñ

1
  • 2
    But the question is how to type tilde ~, not how to type ñ. You should delete this answer since it makes it look like you failed to read the question. Commented Aug 28, 2016 at 18:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .