2

I have two magic mouses, one at home and one at work. Both work just fine over bluetooth with my Macbook Pro (10.9.2), which I use at both places.

Suppose I'm using my home mouse, and then unplug my laptop. If I use my laptop at home next, the mouse with automatically connect. But if instead I bring it to work, the mouse won't automatically connect and I'll have to connect it manually. At which point, I'll have the same problem again: it'll automatically connect to my work mouse, but I'll have to connect my home mouse manually.

This is getting really frustrating. Is there any way I can make both mouses connect automatically?

1
  • I don't have a real answer for you, sorry, but have you tried pairing both mice at the same time? Perhaps this would prevent the Mac from "forgetting" the one which isn't present or "replacing" it with the alternate mouse. Just a thought, and should be easy to try.
    – Turophile
    Jun 15 '14 at 1:50
2

Afaik what happens to you is not default OS X behavior. It should always connect to any input-device that is nearby automatically.

You could try the following:

  1. Remove all bluetooth devices from the bluetooth preferences
  2. Delete com.Apple.Bluetooth.plist from /Library/Preferences and/or ~/Library/Preferences (once I had it in both... not sure why)
  3. Reboot
  4. Pair devices again

  5. Reset your PRAM by holding ⌘ Command+⌥ Option+P+R after pressing the power button when turned off. Hold it until the startup-chime is heard for the 2nd time.

1
  • thanks for the edit Rob, i was copy-pasting, didn't look to well at the writing Jun 15 '14 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .