1

When I use an external drive via usb, my computer really slows down giving me no choice except reboot.

I watched memory usage with activity monitor. Free memory decreases by time and inactive memory increases with the same amount and others don't change much. If I continue using -esp. reading-, free memory comes below to 100MB and then increases a bit -I think it starts paging =other applications' memories= to system disk-, then continues to decrease. Closing the application -that use the external- do not relese memory from inactive to free but ejecting the external does. After unplugging and trying to use the other applications, I face very sluggish performance so that rebooting becomes a better-fast choice. Both NTFS and FAT partitions produce the same result and I don't have any other partition.

If I try to re-read the same file after the external drive stops spinning (sleeps), it does not start spinning but trying to read another file makes it start spining. This makes me think about some -overdone- caching problem, but don't know what causes it and how to turn it off (Tuxero's caching is already disabled in the preferences, although I think it is only for writing only).

I made some research and found nothing specific; they tell to reinstall the os or format the drive -to HFS+ -. What is causing this?

Note: All of my drives are in Spotlight's exclusion (privacy) list and using another usb slot did not change a thing.

My EtreCheck is:

EtreCheck version: 1.9.11 (43) - report generated June 15, 2014

Hardware Information:
    MacBook Pro (13-inch, Mid 2009)
    MacBook Pro - model: MacBookPro5,5
    1 2.26 GHz Intel Core 2 Duo CPU: 2 cores
    4 GB RAM

Video Information:
    NVIDIA GeForce 9400M - VRAM: 256 MB

System Software:
    OS X 10.8.3 (12D78) - Uptime: 0 days 1:4:54

Disk Information:
    Hitachi HTS5450 disk0 : (160.04 GB)
        disk0s1 (disk0s1) <not mounted>: 209.7 MB 
        Macintosh HD (disk0s2) / [Startup]: 94.62 GB (48.81 GB free)
        Recovery HD (disk0s3) <not mounted>: 650 MB 
        BOOTCAMP (disk0s4) /Volumes/BOOTCAMP: 64.57 GB (44.49 GB free)

    HL-DT-ST DVDRW  GS23N  

USB Information:
    Apple Inc. Built-in iSight 
    JMicron Storage 500.11 GB
        BKPFAT (disk1s1) /Volumes/BKPFAT: 443.2 GB (25.08 GB free)
        BKPNTFS (disk1s2) <not mounted>: 56.9 GB 
    Apple Internal Memory Card Reader 
    Apple Inc. Apple Internal Keyboard / Trackpad 
    Apple Computer, Inc. IR Receiver 
    Apple Inc. BRCM2046 Hub 
        Apple Inc. Bluetooth USB Host Controller 

Configuration files:
    /etc/hosts - Count: 1

Gatekeeper:
    Anywhere

Startup Items:
    TuxeraNTFSUnmountHelper: Path: /Library/StartupItems/TuxeraNTFSUnmountHelper

Launch Daemons:
    [loaded]    com.adobe.fpsaud.plist Support
    [loaded]    com.barebones.authd.plist Support
    [loaded]    com.barebones.textwrangler.plist Support
    [loaded]    com.google.keystone.daemon.plist Support
    [loaded]    com.oracle.java.Helper-Tool.plist Support
    [not loaded]    de.jinx.SmartSleepDaemon.plist Support
    [loaded]    org.macosforge.xquartz.privileged_startx.plist Support

Launch Agents:
    [loaded]    com.google.keystone.agent.plist Support
    [loaded]    com.oracle.java.Java-Updater.plist Support
    [loaded]    org.macosforge.xquartz.startx.plist Support

User Login Items:
    GrowlHelperApp
    Google Drive
    witchdaemon
    BetterTouchTool

Internet Plug-ins:
    JavaAppletPlugin: Version: Java 8 Update 05 Check version
    FlashPlayer-10.6: Version: 12.0.0.38 - SDK 10.6 Support
    QuickTime Plugin: Version: 7.7.1
    Flash Player: Version: 12.0.0.38 - SDK 10.6 Outdated! Update
    o1dbrowserplugin: Version: 5.4.2.18903 Support
    googletalkbrowserplugin: Version: 5.4.2.18903 Support
    Silverlight: Version: 5.1.30317.0 - SDK 10.6 Support
    Unity Web Player: Version: UnityPlayer version 4.1.5f1 Support
    iPhotoPhotocast: Version: 7.0

Safari Extensions:
    Bing Highlights: Version: 1.0.20
    ClickToFlash: Version: 2.5.1

Audio Plug-ins:
    AirPlay: Version: 1.7 - SDK 10.8
    iSightAudio: Version: 7.7.1 - SDK 10.8

iTunes Plug-ins:
    Quartz Composer Visualizer: Version: 1.4 - SDK 10.8

3rd Party Preference Panes:
    Flash Player  Support
    FUSE for OS X (OSXFUSE)  Support
    GamePadCompanionPrefPanel  Support
    Growl  Support
    Java  Support
    MenuMeters  Support
    SmartSleep  Support
    Tuxera NTFS  Support
    Witch  Support

Time Machine:
    Time Machine not configured!

Top Processes by CPU:
        25% firefox
         4% activitymonitord
         4% WindowServer
         1% hidd
         1% BetterTouchTool

Top Processes by Memory:
    254 MB  firefox
    111 MB  Google Chrome
    66 MB   Sublime Text
    61 MB   mds
    59 MB   Google Chrome Helper

Virtual Memory Information:
    1.72 GB Free RAM
    1.21 GB Active RAM
    416 MB  Inactive RAM
    425 MB  Wired RAM
    378 MB  Page-ins
    0 B Page-outs
1

When I've had problems with external drives and OS X, it was because Spotlight was indexing the drive, deleting (or losing) the index, and indexing again. It's very process intensive. I simply remove my external drives from the Spotlight index.

System Preferences > Spotlight > Privacy > and add your drive to the list of devices Spotlight should ignore.

http://support.apple.com/kb/PH14049

Apparently, you can also create a file called ".metadata_never_index" on your disk and this will do the trick as well. I've never done it this way. YMMV.

https://discussions.apple.com/thread/5486948

You can do this from the terminal by keying

touch "/Volumes/Your Volume Name/.metadata_never_index"

Or by simply creating a blank file and renaming it that.

  • All of my drives are in Spotlight's exclusion (privacy) list; I forgot to mention, sorry! – Abuzettin.H Jun 14 '14 at 23:15
  • @Abuzettin.H I've not experienced anything like this, then. You get the same result using different USB ports on the machine? I likely can't help you beyond that post, which I'll probably delete. – ezgoodnight Jun 14 '14 at 23:18
  • Using another usb slot did not change a thing, sorry! – Abuzettin.H Jun 14 '14 at 23:35
  • Have you tried safe mode to see if the problem persists? Just this morning I saw that Google Drive was causing problems with my new install of Mavericks and causing Finder to crash. You're using FUSE to read the drive? – ezgoodnight Jun 15 '14 at 2:08
  • OSXFuse is for Truecrypt, nothing should be using it to read and it also happens in FAT drives (native driver). I will try safe mode -rebooting once in a safe mode, then in normal without doing anything- but I don't -sense to- expect any benefit from it :(. – Abuzettin.H Jun 15 '14 at 3:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .