3

I am a programmer, and often I have words in all lowercase, not seperated by a space or hyphen.

In some *situations OSX will sometimes change infoclass to info class for instance

*context aware I'm sure

This feature has breached my annoyance ceiling. Is there anyway to turn it off?

I enjoy autocorrect, just not the word splitting feature.

3

Navigate to System Preferences > Keyboard > Text > Correct Spelling Automatically (uncheck)

If you wish to leave autocorrect on, but create certain exceptions, you can alternatively leave it checked and in the same pane add, for example:

Replace: infoclass With: infoclass

This sets up an exclusion of sorts so that autocorrect does not change it to info class

  • 1
    Thanks, I enjoy autocorrect, just not the word splitting feature. – AshCooman Jun 13 '14 at 3:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .