2

I ran the following command by mistake:

sudo chmod 744 ~/..

and I can't boot my macbook anymore, it freezes with the brown screen and ajax-style spin. What should I do to make it work normally again?

I tried:

a) Disk utility (repair permissions) - didn't help b) resetpassword -> reset ACL and permissions for home directory - didn't help.

I booted in the recovery mode, opened the terminal and went to "/Volumes/Macintosh HD". Yes, this was the disk (or should I say "path") I changed the permissions for.

How do I restore them now? And what are they were?

UPDATE:

I was able to restore it by going to the terminal in recovery mode and performing:

chmod 777 "/Volumes/Macintosh HD/"

But I believe that 777 is too much. What's the default umask for ~/.. ?

UPDATE2:

I don't know why it worked since ~/.. means /Users, not /.

  • It's on my machine: drwxr-xr-x 8 root admin 272 27 lut 14:53 .. – Mateusz Szlosek Jun 12 '14 at 15:47
  • @MateuszSzlosek, and what's the umask for that? – アレックス Jun 12 '14 at 15:48
  • @MateuszSzlosek Really? No ACLs? – grg Jun 12 '14 at 15:48
  • that's my output from ls -la inside $HOME how to check umask ? – Mateusz Szlosek Jun 12 '14 at 15:53
  • @MateuszSzlosek, it can be calculated from "drwxr-xr-x", let me check. – アレックス Jun 12 '14 at 16:00
2

I would do two things to restore a Mac in this situation.

  1. boot to recovery mode and run Disk Utility - repair the drive, the volume and then repair permissions.
  2. Boot to recovery mode and run the installer. That should fix or log the exact directory that has improper ACL/permissions and re-create all basic mount points.

The installer log can be read in recovery mode boot if step 2 doesn't fix things and we can perhaps refine exactly what directory or directories are now messed up. There is a chance that you had a separate failure and your chmod was coincidental to the issue as opposed to causative.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .