I accidentally deleted the wifi connection on my macbook pro (I went to System Preference > Network, i tried to delete a VPN but accidentally deleted the WIFI connection as well). Now if I add a WIFI again using the + sign, it does not gets added. The wifi sign the top bar shows a cross on it. I have restarted my system and used different logins but it id not adding the wifi again. I also also used different names but it did not work. I need this fix asap.

  • are you sure your network is available? – dennismuijs Jun 12 '14 at 11:49
  • it is not about network, it is about installing the wifi adaptor I guess. Basically wifi should show up in the list of networks before it can be connected to an available network. – mac_user Jun 12 '14 at 11:51
  • have you checked this question: apple.stackexchange.com/questions/134727/… – dennismuijs Jun 12 '14 at 11:52
  • That is helpful post but the problem in my case, if I add wifi using + sign, it does not get added. if I do it with any other type like thunderbolt, it does gets added. – mac_user Jun 12 '14 at 12:00
  • you turned off the wifi, check in about this mac – Ruskes Jun 12 '14 at 12:01

In Terminal type this command :

sudo ifconfig en1 up

sudo ifconfig en0 up
| improve this answer | |

I know this post is old, however I just want to share my solution for the problem, because the problem almost made me nuts and I hope my solution is simple enough and works so someone doesn't have to pull his/her hairs off.

This is my simple solution that worked (at least for me). :

  • Goto System Preferences and then goto Network.
  • When the Network screen appears, find the Location combo and delete all location that you find in there.
  • Now you are left out with only one Location, that is 'Automatic'.
  • Find the plus sign at the left bottom o Network screen, click it to add new interface, when interface list appears, choose Wi-fi and click create.
  • There, you should now see a Wi-fi interface added to the left hand side list.
  • Click Apply to save.
  • That's it, Hope this helps.
| improve this answer | |
  • You solution may be the right one, which I cannot test unfortunately right now. But thanks for adding the answer. I have also added my own answer which at the time I forgot to post. Thanks – mac_user Sep 27 '18 at 7:14

The problem here was sort of hidden. One of the connection on the left hand side has Wifi Interface selected which was in fact NOT wife device. You have to check all of the connection to find out the culprit. Detail is in the link below

Fix Wifi Connection problem on Mac - Mac will not connect to wife

| improve this answer | |

I had the same issue - pressing the Plus sign and adding a missing Wi-Fi interface did nothing. I tried sudo ifconfig en1 up but it didn't work.

The reason was that Wi-Fi somehow became a part of Thunderbolt Bridge interface, even though during troubleshooting I tried deleting all interfaces including the Thunderbolt Bridge one.

Here is how I fixed the problem:

  1. Go to System Preferences -> Network.

  2. If you don't have a Thunderbolt Bridge interface on the right hand side, create one using the Plus button.

  3. Press the Gear button -> Manage Virtual Interfaces.

enter image description here

  1. Press the Edit (Pen) button.

enter image description here

  1. If you have both Wi-Fi and Thunderbolt interfaces checked than that's it - go ahead and uncheck the Wi-Fi interface.

enter image description here

  1. Press Done, Apply, and so on.

Hope this helps somebody.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .